Community Forum

Bigger Sky

Forum Overview >> Editor

CategoryEditor
Created13.11.2016 22:05


Jakub Pandadis (pandacze) 13.11.2016 22:11
Hello, I have 4x map and I need set a bigger sky. I copy a sky folder from game and make sky i3D model bigger, but than I change a path to sky in map01_enviroment from environment filename="$data/sky/sky_day_night.i3d" to environment filename=" map/sky/my_sky.i3d ... In a game I see only black space, no sky. Somebody know how to fix it? Thanks for help. (FS17)

Yuri Pushkarev (unknown) 11.01.2017 19:21
I know! But I am is russian man and understand english very bad..((

Rob Van Den Berg (thudge) 12.01.2017 16:07
In the Farming Simulator install folder you will find game.xml. Configure game.xml to write logging messages, for example like this:
<logging>
<file enable="true" filename="log.txt"/>
</logging>

Open your map mod again, and now you can inspect log.txt ( in the same folder ) to find out what's going wrong / which textures couldn't be found.

My guess would be the (location of the) skyShader.xml file (mentioned in your my_sky.i3d file) as that's what tricked me the first time.

William Rowe (Bonger76) 12.01.2017 22:51
im having the same problem you can open the sky.i3d from my map in GE no errors have the pathes as
<environment filename="sky/mod_sky.i3d" dayNightCycle="true" startHour="8" allowRain="true" autoRain="true" sunHeightAngle="-70">
then get this error when opening map in game,
Warning (Script): Unknown entity id 0 in method 'getChildAt'.
LUA call stack:
dataS/scripts/environment/Environment.lua (58) : getChildAt
dataS/scripts/missions/mission00.lua (223) : new
dataS/scripts/missions/mission00.lua (111) : loadEnvironment
dataS/scripts/FSBaseMission.lua (1030) : load
dataS/scripts/gui/MPLoadingScreen.lua (194) : onConnectionRequestAcceptedLoad
dataS/scripts/gui/elements/Gui.lua (306) : update
dataS/scripts/main.lua (1858) : update
data/sky/rain.i3d (2.45) ms
data/sky/hail.i3d (1.26) ms
data/sky/dust.i3d (1.13) ms

then get this LUA call stack
Warning (LUA): 'setShaderParameter': Argument 1 has wrong type. Expected: Int. Actual: Nil
..\..\..\src\base\scripting\lua\LuaScriptSystem.cpp (630): expectedType == Value::VoidType
LUA call stack:
dataS/scripts/environment/Environment.lua (384) : setShaderParameter
dataS/scripts/BaseMission.lua (1699) : update
dataS/scripts/FSBaseMission.lua (2159) : update
dataS/scripts/missions/mission00.lua (333) : update
dataS/scripts/main.lua (1862) : update
Warning (LUA): 'setShaderParameter': Argument 1 has wrong type. Expected: Int. Actual: Nil
..\..\..\src\base\scripting\lua\LuaScriptSystem.cpp (630): expectedType == Value::VoidType
and get a black sky,haveing same problem with the trains but get trainsystem lua, errors.

as of right know i just edited the sky and left it in the data/sky/mod_sky and works fine but just about done with the map and need to get the sky and train to open from the map so that i can release it.


Mngrazy Grazy (mngrazy070778) 15.01.2017 11:00
not working !
fixed in patch 1.4 maybe ! ;)

Thomas A. (thediabl0) 17.01.2017 14:44
are you sure? xD

William Rowe (Bonger76) 18.01.2017 22:57
OK trying to going at this a different way made a map .lua to open my map got it open and work with the first basic stuff the old way to open the sky dont work ,the sky open when load map but get differnet error and game crashes forgot to copy errors I tried some thing else and it just crash game with no errors in log,has something to do with the enviroment .xml tried with enviroment.onCreate and xmlFilename attributes in the sky.i3d and that crashed game to thier must be some way to get it to open from map.lua just dont know that much on scripting if any one might have any ideas(like GIANTS hint hint) im going to try to get the map.xml to open from my map.lua and see what happens.

William Rowe (Bonger76) 18.01.2017 23:33


Mngrazy Grazy (mngrazy070778) 19.01.2017 15:43
working in 1.4 !!!
giants say it will be fixed in the next patch !

William Rowe (Bonger76) 19.01.2017 18:26
Thanks,

Derek Latham (ragworm) 21.02.2017 19:11
Just fixed mine with your help but you must put the shader.xml in the correct folder which is the shader folder before the map folder


Note: Log in to post. Create a new account here.