Community Forum

editor fails to open any map

Forum Overview >> Editor

Created27.11.2016 04:08

Ed Berwanger (Unknown) 27.11.2016 04:11
I installed editor and i can open any mod but will not open a map. I have tried several maps. Windows 10 closes program

Nick Nick (Unknown) 27.11.2016 11:34
hi. maybe it was created with a lower version. You try to install a lower version and see if it opens the project. I happen such a thing.
I apologize for my english is not perfect

Mike Scott (ms62347) 29.11.2016 03:58
I am also having the same problem of not being able to open maps to edit, I tried other files and was able to open some of them. Itried removing 7.0.5 and tried other previous versions but no luck either. I am running Windows 10 also. Not surewhat is making it open and display, "Program Not Responding". Any help would be appreciated.

Ian Muddle (IanM4850) 29.11.2016 08:18
I'm having the same issue Windows 10 Have tried all the editor versions and none can load a map id3.
They all start up but stop responding when you either open or import a map.

James Norred (Cajunwolf) 29.11.2016 08:33
Have you tried opening it by mod description?

Chuck Seco (Unknown) 01.12.2016 21:28
same problem here says GE has stopped working every time i go to open a map.

Ed Berwanger (Unknown) 02.12.2016 19:45
its a windows issue

Tony Price (brownthumb) 03.12.2016 06:13
not a windows issue, am running windows 10 and i open maps every day, make sure you are not trying to open a FS15 map with a FS17 editor

James Norred (Cajunwolf) 05.12.2016 05:00
Well it certainty sounds like something is seriously broken, be it Windows or the editor, and if your reloading the editor each time and it's doing the same thing, I would look into a Windows issue that has popped up for some reason, or perhaps you changed video drivers, or Windows did it on an update (this has happened to me). What I'm saying here is that there are many possibilities so don't be closed minded.

Fdr Logging (firstdayreviews) 08.12.2016 10:57
man same issue here, pretty pissed off. I worked on a new map for over 2 hours, saved it fine then went to open it and boom program not responding, This seriously sucks for trying to update or make new maps based on old ones, needs a fix asap

Adam Houston (Unknown) 13.12.2016 21:36
same problem its crashing every time a try to open a map

Bilbo Beutlin (BBeutlin) 14.12.2016 00:59
There are a few incompatiblities within the GE versions.
If these errors occur, first of all make sure, you open the i3d with the GE version it was created (see beginning of i3d in text mode)
Then do an "export all with files" and try to re-open the output in a later GE.
If negative, most probably the i3d is corrupted. If you're quite firm in XML, you could check the i3d in text mode - its all XML.

Jeremy Nelsen (Unknown) 29.12.2016 04:44
Same problem here. Is version 7.0.5 compatible with FS 15 or just fs 17?

James Lewis (jimjunior) 13.01.2017 17:33
So, WHATS THE FIX? Either Culprit? How do I go about pin-pointing the problem? Windows & GE.

Tony Price (brownthumb) 14.01.2017 16:51
some reasons why 7.0.5 won't work, trying to open something from fs15, graffic card is not big enuf, not enuf ram, trying to use it on older laptops, there it runs into both grafic and ram issues,and for some reason i have found that windows sometimes will not lock in usable ram, so have had to go to msconfig: boot: advanced: to reset usable ram, hope something there helps.

Carsten Schmidtke (Casi848) 16.01.2017 12:04
Have problems to open mods and maps at all
Tried to open mods
got this messages in the editor

Warning: Shape col1Front with id 8 not found. Replace with empty transform group.
Warning: Shape col2Back with id 7 not found. Replace with empty transform group.
Warning: Shape col2Front with id 8 not found. Replace with empty transform group.
C:\Users\Casi0\AppData\Local\Temp\\stollLargeBaleForkH.i3d (20.91) ms
Check for updates (

Try to open maps for example the "Fichtelberg " I like the map but would like to do some minor changes in regards to fencing and building, I think it is a bit to much, but just my opinion and would not publish my changes.But GE runs dead and after a while, widows is shutting it down.
Any help or idea what I do wrong.
Pls explain it easy, I`m not a modding or PC specialist

Note: Log in to post. Create a new account here.