Community Forum


Forum Overview >> Editor

Created02.12.2016 06:52

Tony Price (brownthumb) 02.12.2016 07:08
if you have an empty mod map that has only 1 field in it's field folder and you make many fields, how does one duplicate and set everything up so that the game recognize's each field for it's size, shape, price, and still have it's missions?

Michael Hudson (Unknown) 02.12.2016 10:43
Duplicate Field01 in fields Folder, and rename Field02 and so on, you will have to set fieldMapIndicators for each field, and the fieldBuyTrigger.

Then you will need set extra field dimensions.
Duplicate corner01_1 and rename Corner02_1 then Corner02_2 and finally Corner02_3.

In GE highlight Fields Folder then go to Menu/Scripts/FS17/Map and Toggle Render Field Areas, This will show your field areas.
Also Set Field Sizes will calculate fields for you

There is a good explanation here:

Tony Price (brownthumb) 02.12.2016 13:50
tried setting up a simple 4 corner field, but when i highlight fields folder and toggle Render Fields Area and Set Field Sizes i get Error: Please select fieldDefinitions root!. if that means selecting the fieldDefinitions thing inside the folder for the field itself i tried that too with same results. what am i doing wrong?

Michael Hudson (Unknown) 02.12.2016 15:56
Have you brought your fields into map yet?
Then you select fields transform group, sorry not Fields folder, then Toggle Render Field Areas

Tony Price (brownthumb) 03.12.2016 06:32
doesn't matter what or how i do, still get the same error:...Error: Please select fieldDefinitions root!, have yet to find anything anywhere that can point me to the field Definition root, or what it means.

Bruce Hay (Stussy) 04.12.2016 03:01
I was having the same problem, however Michael's reply did work, make sure you select the first level of fields on the Scenegraph, then toggle Render Fields, then Set Field Sizes, works a treat!

James Norred (Cajunwolf) 18.12.2016 14:46

Douwe Kerstma (Unknown) 22.02.2017 19:37
still don't work here.
, first off... my english is not that good but i think i understand what i was supposed to do.

if i try to render or set the field at the orginal maps in GE it works like it supposed to be.

but in my own made map it still don't work.

i did do what micheal hudson told us.

is there someone who can help me pleace?? , i've lost hours to try it all out and i don't know what to do anymore

Jonathan Monks (Unknown) 05.11.2017 14:05
I notice this is an old thread but as a solution has not been publicly posted I thought I would contribute.

So I had a blank map that had no fields!
I managed to get this working from ground zero (not even having a root 'fields' folder to begin with).
I too encountered the dreaded 'error:Please select fieldDefinitions root' message.
This is how I solved it.

First I created a transform group called 'fields' (the root folder thats required for all fields).
Then I exported/imported 'field01' from GoldCrest map and used that to border my field in the new map.(making sure field01 was put within the root group of course)

However, to fix the error (and I will assume those that still encounter this even if they have the root folder selected will be for the same reason)...

Because I had to create the root folder myself, when I compared it to the goldcrest 'fields' transform group, in the User Attributes, it has a script entry that you will need to also have set up in your blank/custom map.

To do so, make sure the 'user attributes' window is open when you click 'fields' in your scenegraph.
If you've created it by hand, or somethings gone wrong and the entry is missing, first:

.select 'script callback' in the dropdown menu in 'user attributes'.

.in the textbox type 'onCreate' (minus quotations)

.Click Add

A new entry called OnCreate with a blank textbox beside it should have now appeared.

In that blank text box copy paste the following: 'FieldDefinition.onCreate' (minus the quotations).
Save your map!

Now, when you highlight 'fields' and run the two scripts 'set field sizes' and 'toggle render field areas' they should now both execute without that error!

Hope that helps any future encounters!

Peter Du Pree (highdesert) 20.12.2017 03:31
@Jonathan Monks

Thanks, Jonathan! Very good, concise explanation. Did the trick for me.

Note: Log in to post. Create a new account here.