Community Forum

7.0.5 Crash

Forum Overview >> Editor

Created17.12.2016 20:50

Eric Crawford (Unknown) 17.12.2016 20:52
Updated to 7.0.5 64 bit, program crashes everytime I open it, I reboot my system and also reinstall the program still no change.

Brice Edseth (Unknown) 20.12.2016 18:51
Same here, It was working great this morning

Brice Edseth (Unknown) 20.12.2016 18:53
I installed 7.0.0 from the sdk in FS17 main folder (not where the mods go) and it launches up with no issues.

Derek Berghout (Unknown) 01.01.2017 03:52
i got same problem as well..used editor for few hours earlier and come back to it and when i try to open it windows 10 says GE has stopped running?..7.0.4 does same thing

David Johnson (dajnet) 06.01.2017 23:59
I am now having this same issue, any word on how to fix it?

Austin Jordison (Unknown) 07.01.2017 00:35
I've tried 7.0.2 and 7.0.5 both crash as soon as I load in a mod, I haven't been able to do anything with mods for 2017.

Cody Stone (Unknown) 10.01.2017 07:07
Anyone have problem with it crashing before you even put in a mod?

Cody Stone (Unknown) 10.01.2017 07:09
Anyone have problem with it crashing before you even put in a mod?

Spencer Wood (Unknown) 13.01.2017 03:09
I tried to download 7.0.5 64bit and Norton deleted the file before I could open it saying there was a Trojan embedded and the download was not safe to run. I hope Giants fixes this soon.

Ted Fanning (wickedset) 15.01.2017 11:12
Did you download from this site only? If you did then there is not a Trojan embedded and Norton is your problem, just make sure you are ONLY downloading from the downloads page on this site after logging in, and do not follow any links to this site, type this address into your browser:

type nothing else, then login.

Note: Log in to post. Create a new account here.