Community Forum

Error when loading i3D file: Parse Error in line 924999

Forum Overview >> Editor

Created27.09.2010 00:45

Ryan Sss (Unknown) 27.09.2010 00:49
Heey Guys

I was editing my map and suddenly the editor didn't respond anymore and crashed.

Then when i started the editor again it saidL Error when loading i3D file.

The log says:

Driver: NVIDIA PhysX Runtime
Version: 2.8.1
Driver: OpenAL Software
OpenGL Rendersystem
Card Vendor: ATI Technologies Inc.
Renderer: ATI Mobility Radeon HD 4870
Version: 3.3.10151 Compatibility Profile Context
GL_NV_texture_compression_vtc not supported
GL_NV_vertex_program2_option not supported
GL_NV_vertex_program3 not supported
GL_NV_register_combiners2 not supported
max_texture_layers: 8
GL_NV_fragment_program_option not supported
GL_NV_fragment_program2 not supported
OpenGL initialization successful
GPU profile: High
View Distance Coeff: 1.5
Shadow Quality: 1
Skip Mipmaps: 0
Terrain LOD Distance Coeff: 1.5
Check for updates (
Error: Mesh with zero triangles
Parse error at line 924999:
no element found

I understand there should be a problem in the line with 924999. I have two lines short after each other with this number 924999. I tried replacing them both from an slightly older back up of the map but i still get the same error.

I'm a little bummed because i created a few things and i don't want to start that over again actually.

How can i fix this problem?

I use editor 4.1.2.

Stefan Geiger - GIANTS Software 27.09.2010 19:04
There is an error on the line number 924999. It is not a line with 924999 in it.

You can view this line by using the tool of your text editor called "Goto Line" or something similar.

Ryan Sss (Unknown) 27.09.2010 20:04

I found out that that line was an empty line after </FoliageMultiLayer\>

I found in my back up from the day before that there was a lot missing behind that line.

So i copied and paste some and yes my map was working again. Only all of my objects where gone. So I found out I didn't copy the part with transformgroups of my objects.

So I copied the part from the foliagemultilayer to the end of the script(from the back up) and pasted it into the map i was working with.

When I start the map with GE my objects look strange, are at the wrong position or are extremely big.

How can I combine those two maps?

In the one that crashed yesterday, my terrain and textures are allright but there are no objects.

In my back up i miss the part I build yesterday, the terrain and the objects i placed there. But everything i did before of objects are still there.

Is there a way to put those two together?

And thanks for your help btw!

Stefan Geiger - GIANTS Software 29.09.2010 11:16
Merging the objects probably might be tricky.

But you can easily merge the new terrain data to your old backup. Simply copy all grle files over. As well as the .._weight.png and ..._dem.png.

Note: Log in to post. Create a new account here.