Community Forum

GE 7.0.5 does not work correctly under Windows 10

Forum Overview >> Editor

Created02.01.2017 17:20

Wolfgang Stadler (Wolpertinger_2000) 02.01.2017 17:27
Hi @all,

every time when I click on a object or a tree item in scenegraph 1 processor get up to 100% and I have to wait about 1 to 2 minutes until GER will response again.

With this issue it's not really possible to edit a map. This didn't happen with GE 7.0.0 to 7.0.4.

Is there a workaround to solve this issue as I deleted all further setup files and it is not possible for me to go backt to 7.0.4.

Thanks in advance

Bilbo Beutlin (BBeutlin) 03.01.2017 01:02
Usually this happens if you have used 'illegal' characters for labels or text.
Make sure, you use only ASCII characters "a-z", "A-Z", "1-0", "_" (underscore). Labels must begin with a letter and shouldn't contain spaces - use "_" instead.

But may also be, your i3d is corrupted elsewhere. If you're quite firm in XML, you could check the i3d in textmode - it's all XML. Notepad++ is very suitable, it has syntax highlighting.

Wolfgang Stadler (Wolpertinger_2000) 03.01.2017 11:31
Unluckily it's the same when I open the original delivered map01.i3d. As I mentioned the problem wasn't with the further versions, it came up with 7.0.5. I have an older Laptop with Win7 and there all is working fine with the identical files. So I think it's the combination of Win10 and GE 7.0.5.

Bilbo Beutlin (BBeutlin) 03.01.2017 12:21
Do you have enough system RAM? A map eats lot of it and swapping memory could be a reason for the slowdown.

Did you perhaps bypass access to user files to cloud storage? That might also lag significiantly.

Could also be, something went wrong on installation. Did you install the GE properly (with rightclick) "as adminstrator"?

Rob Van Den Berg (thudge) 03.01.2017 12:21
I experience no problems with the Win10 - GE 7.0.5 combination.
Just guessing based on your observation that the map is editable nicely on your Win7 installation: does switching to a lower profile help ( View -> Profile -> Low) ?

Wolfgang Stadler (Wolpertinger_2000) 03.01.2017 14:50
I have 16 GB RAM and a i7-6700K with a AMD R9 Fury Card. The files are all stored local.

I tried a new installation as administrator and also set the Profile to low. But it didn't change anything. 1 thread is rushing up 100% and I have to wait (I stopped it now) 3 minutes til I can click on the next object and then again waiting 3 minutes.

Bilbo Beutlin (BBeutlin) 03.01.2017 15:30
That's curious.
Does the "editor_log.txt" contain any errors/warnings?
Look also into Windows' event logs (dt: Ereignisprotokolle). Maybe there's something indicated in conjunction with GE.

Try also executing GE "as administrator". Does this change anything?

What about your gfx driver? Do you have extraordinary settings? screen resolution, multi display, refresh rate, freesync, ... ?
Take a look into driver settings. Has the GE individual settings which differ from global settings?
In my Nvidia driver the GE is identified falsely as "Crysis editor" and I had to reset to defaults.

Wolfgang Stadler (Wolpertinger_2000) 04.01.2017 10:48
So I tried some things:
- Reinstall of GE including deleting of the editor.xml, running GE with compatibility mode with and without administration mode
- Also I have the newest gfx driver and there are no strange settings, GE is running with default settings.
- I also tried to change the priority of GE in Task Manager wit no effects.
- Windows event logs do not say anything about GE.

Navigation over the map without clicking any object is doing well. Its only when I click on an object that one cpu thread is running on 100% and the other seven are idling. For the completeness I will attach the editor log, but it looks good for my opinion, except the long loading time of the standard GCV map.

By the way FS itself is running stable with 60 FPS and no frame drops (I have VSync switched on)

GIANTS Engine Runtime 7.0.0 (13783) 64bit (Build Date: Nov 21 2016)
Copyright (c) 2008-2016, GIANTS Software GmbH (, All Rights Reserved.
Copyright (c) 2003-2016, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 7.0.5
Main System
CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
Memory: 16317 MB
OS: Windows NT 10.0 64-bit
Physics System
Version: 5.9.5
Thread(s): 2
Sound System
Driver: OpenAL Software
Render System
Driver: OpenGL
Card Vendor: ATI Technologies Inc.
Renderer: AMD Radeon (TM) R9 Fury Series
Version: 4.5.13464 Compatibility Profile Context 21.19.384.0
Shader Version: 4.50
Max. Texture Layers: 16
Started 4 threads for threadpool 'Render threadpool'
Hardware Profile
Level: Low (forced)
View Distance Factor: 0.750000
Shadow Quality: 0.000000 Size: 1 Filter-Size: 4
Shader Quality: 0
Skip Mipmaps: 1
LOD Distance Factor: 0.750000
Terrain LOD Distance Factor: 0.750000
Terrain Normal Mapping: Yes
Foliage View Distance Factor: 1.000000
Foliage Density: 0.300000
Volume Mesh Tessellation Factor: 1.500000
Tyre Tracks Segments Factor: 0.500000
Max. Number of Shadow Lights: 0
Max. Number of Lights: 512
Max. Number of Lights Per Cluster: 32
Check for updates (
S:\Farming Simulator 2017\data\maps\map01.i3d (15049.25) ms

Bilbo Beutlin (BBeutlin) 04.01.2017 11:59
Which process is running with 100% if you click on something? Is it the GE process or a system/input process?
(use taskmanager or ressource monitor to determine).

Are you using a normal USB mouse? or something with a special driver?
If possible, try another mouse, just a standard model without special features. Also try another USB socket.
The reason: the Giants engine has sometimes problems with strange input devices and drivers.
Could also be, on your currently used USB socket is a driver for another/earlier USB device installed. There Windows has still problems to 'forget' unused drivers.

Wolfgang Stadler (Wolpertinger_2000) 04.01.2017 16:53
So it's not a process which is running with 100% but 1 CPU Core is running on 100% when I click on an object in GE. And it's always Core 0. The process itself uses then 12% of the total CPU.

I normally use a Logitech G502 mouse. I changed it against a normal USB mouse (which is normally on the Laptop) on a different USB socket but this makes no differences. I also checked the system against old unused drivers and cleared it up. Again with no changes.

So I think I have to live with this problem. As GE is the only application making waves I will not setup the complete system to a fresh installed one.

But thanks for your help anyway.

Bilbo Beutlin (BBeutlin) 05.01.2017 01:22
The GE process takes 12% ?
Then there must be another process very busy. Try to determine which one. This should give hints what causes the lags.

You'll get the infos with the Windows' ressource monitor. Look also into the other tabs for heavy file/data or network traffic.

William Rowe (Bonger76) 05.01.2017 04:23
I started getting lag with GE after i added around 3500 trees so i stop adding any trees till it is the last thing I do on my map,I have seen the same thing on other videos of other people making maps get super slow after they add alot of trees.

Wolfgang Stadler (Wolpertinger_2000) 05.01.2017 09:30
The resource monitor says that GE needs about 12% and 1 core is running on 100%. That means GE is taking one core to 100% and not using any other core at the same time. And that for 3 minutes. All other 7 cores are idle at the same time. As the i7 has 8 cores this math is totally right. Before that mess happened GE used more than one core and all was running smoothly.

Bilbo Beutlin (BBeutlin) 05.01.2017 13:18
What I meant: if the GE uses a CPU for 100% but for about 3min nothing happens - there should be another process which is significiantly busy. Perhaps a system/input process or similiar from where the GE expects an answer. This would explain the difference to Win7, since Win10 might have massive changes there.

I could also imagine, on your system is an obsolete driver, which isn't 100% Win10 compatible. Or the opposite: the Win10 auto-update has overwritten a working driver. You were not the first, who has trouble with this.

Since I read rarely about such problems with GE like yours, I'd assume an issue in your individual system configuration.

Brad Robinson (Unknown) 04.05.2017 01:56
I am having this exact same problem after updating to 7.1.0.

I have an i7 6700k 1080 GTX PC and I updated to 7.1.0 and maps keep freezing if I click on an object. I tried deleting a reinstalling and used CCleaner to get rid of the old Registers but it still won't work. I even created a new Windows account and installed GE on a completely separate windows account but the same thing happens. I tried going back to 7.0.5 and still the same problem.. I just cannot figure it out.

The same maps open fine on my crappy laptop.

Bilbo Beutlin (BBeutlin) 05.05.2017 13:56
In many cases a wrong installation causes these errors.

1. Due to Windows' restrictive UAC/DEP you shouldn't install the GE in the default directory "C:\program files...", but in a neutral directory which isn't touched by UAC.

2. You MUST install the GE under full admin rights: RIGHTclick on the GE setup.exe -> "Run as Administrator"

3. Also due to UAC, the GE might not have the rights to access your files in "C:\Users\{your name}". Best is to have the datas in a neutral folder. Otherwise run the GE "as Administrator".

4. The GE also uses datas from FS game installation. You MUST have the FS game installed properly. Also the game needs an installation "as Administrator", else the Win registry cannot be touched and the GE doesn't know about install pathes.

Urban Kavkler (Unknown) 28.10.2017 18:38
hey.i have a problem.i downloaded giants editor and when i wanna to open it it says that i cant create OPENGL wiewport?some people say to me that you need to update graphich card i did but it is still the same.please help me.

Emanuell Lovnicki (Unknown) 09.02.2018 13:43
Same thing i don't really know how to fix it

Ben Gray (bnjgray87) 29.07.2018 20:11
Ive now encountered the same problem as Brad has described. GE is incredibly slow and unresponsive when I load up maps but much small mods like tractors are fine. ,
A mate suggested using DDU and reinstalling nvidia under safe mode and that did restore some normality to GE but, there's been recent windows updates and now GE has slowed right down again. Using DDU this time around has not helped in the slightest so any ideas are welcome.


Note: Log in to post. Create a new account here.