Community Forum


Forum Overview >> Editor

Created30.01.2017 19:52

Bartosz D (Unknown) 30.01.2017 19:54
When i starting the editor it shutsdown. I have tried reinstalling it but still dont works. Please help! PS: i want to make my own map

Bilbo Beutlin (BBeutlin) 31.01.2017 01:45
Look into the "editor_log.txt" - most probably the reason for the error you'll find there.

btw: writing your topic title in uppercase doesn't accelerate an answer. In opposite: several people ignore such topics.

Bartosz D (Unknown) 31.01.2017 09:09
Didn't fine anything there. If you want to check if something frong is there so here:
<?xml version="1.0" encoding="utf-8" standalone="no" ?>
<window_layout x="0" y="0" width="1024" height="768" perspective="" />
<undo stack_size="25" />
<grid enable="false" subdivisions="24" spacing="1.000000" />
<viewport nav_translation_scale="0.050000" nav_rotation_scale="0.004000" framed_rotate="false"/>
<file_recent files="" />
<gizmo size="10.000000" frame_size="2.000000" frame_radius_scale="0.040000" nurbs_curve_picking_cv_radius="1" />
<warning show_save_warning="true" />
<info update_notification="true" />
<logging file="true" />

<i3d force_external_binary_files="false" />
<toolbar name="Scripts 1">
<toolbar name="Scripts 2">
<toolbar name="Scripts 3">
<toolbar name="Scripts 4">
<toolbar name="Scripts 5">

Bilbo Beutlin (BBeutlin) 31.01.2017 20:16
That's the "editor.xml" in install directory.

We need the "editor_log.txt" in "{user}\AppData\Local\GIANTS Editor 64bit 7.0.5"

Bartosz D (Unknown) 01.02.2017 10:28
Found it!

GIANTS Engine Runtime 7.0.0 (13783) 64bit (Build Date: Nov 21 2016)
Copyright (c) 2008-2016, GIANTS Software GmbH (, All Rights Reserved.
Copyright (c) 2003-2016, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 7.0.5
Main System
CPU: Intel(R) Core(TM) i3-3217U CPU @ 1.80GHz
Memory: 5959 MB
OS: Windows NT 6.2 64-bit
Physics System
Version: 5.9.5
Thread(s): 2
Check for updates (
Sound System
Driver: OpenAL Software
Render System
Driver: OpenGL
Card Vendor: Intel
Renderer: Intel(R) HD Graphics 4000
Version: 4.0.0 - Build
Shader Version: 4.00 - Build
Max. Texture Layers: 16
GL_ARB_get_program_binary not supported
GL_AMD_depth_clamp_separate not supported
Started 2 threads for threadpool 'Render threadpool'
Hardware Profile
Level: Low (auto)
View Distance Factor: 0.750000
Shadow Quality: 0.000000 Size: 1 Filter-Size: 4
Shader Quality: 0
Skip Mipmaps: 1
LOD Distance Factor: 0.750000
Terrain LOD Distance Factor: 0.750000
Terrain Normal Mapping: Yes
Foliage View Distance Factor: 1.000000
Foliage Density: 0.300000
Volume Mesh Tessellation Factor: 1.500000
Tyre Tracks Segments Factor: 0.500000
Max. Number of Shadow Lights: 0
Max. Number of Lights: 512
Max. Number of Lights Per Cluster: 32
Error: Failed to create render texture. Status: 36055.

Bartosz D (Unknown) 25.09.2017 18:03
Bump, sry for big text still...

Mike Strano (siver12) 28.09.2017 01:40
So was the problem solved?? I'm having the same issue and don't see anyone that has found a fix. Pls let me know.Going crazy.

Bartosz D (Unknown) 28.09.2017 12:12
No, still waiting D:

Same Sama (Unknown) 30.09.2017 12:07
Had same problem. Upgraded graphic driver. Its working

Bartosz D (Unknown) 06.10.2017 12:15
Still doesn't work after updating, the drivers was updated before I launcher the editor

Emil Drefers (Unknown) 09.10.2017 09:29

there is an interesting error message in the log.txt:
Error: Failed to create render texture. Status: 36055.

This indicates that there are some problems with your graphics card.
So, if we check which GPU you have:
Renderer: Intel(R) HD Graphics 4000

We do realize that you have an onboard GPU.
These GPUs typically lack the support (driver side) for some OpenGL options.
I'm sorry to say, but with this GPU you won't be able to run the GIANTS Editor.


Bartosz D (Unknown) 10.10.2017 17:29
O okay, it isnt so big deal now due to I am getting a new pc, anyway thx

Note: Log in to post. Create a new account here.