Community Forum

Giants Editor v7.1.0 not opening

Forum Overview >> Editor

Created18.09.2017 18:04

Ross Williams (RossMH) 18.09.2017 18:04
Hello fellow modders! I recently moved my PC to another room in the house. I turned it back on in its new place eager to get back to work. I tried to open Giants editor V7.1.0, however it would not open. All the other editors would open, but wouldn't load any i3D files. I don't care about those as much anymore, as we work with 17 nowadays. Anyways here is the error: Can't load xml config file: C:/Users/User/AppData/Local/GIANTS Editor 64bit 7.1.0/editor.xml

I looked on other forums but nothing would help. I reinstalled, ran as admin, changed the path specifically to C:/Users/User/AppData/Local/GIANTS Editor 64bit 7.1.0 however none of these work. If someone could help me out that would be great. This is really frustrating and I want to get back to work ASAP. Thanks!

Mathias Hansen (Matti2206) 18.09.2017 19:35
Helle there! I've got the same excact problem...;(

Rody Oneal (Unknown) 21.09.2017 23:58
same problem as well.

Dallas Logan (Unknown) 24.09.2017 02:19
Im getting a different error. says 'Could not create OpenGL viewport'

anyone know what that means?

Emil Drefers (Unknown) 26.09.2017 10:22

'Could not create OpenGL viewport'
This means that your graphics card is not powerful enough to run the Editor.
Actually the driver of your graphics card is not supporting certain features.
Anyway, with this gpu and driver you can't use the Editor.
Sorry, for no better news.

Can't load xml config file: C:/Users/User/AppData/Local/GIANTS Editor 64bit 7.1.0/editor.xml
That's interesting.
I would have said that this folder exists after installing the GIANTS Editor.
If the folder exists. Try to delete it and start the Editor afterwards.
Or uninstall the Editor, delete the folder and re install the Editor.
Something like that should fix it.
Also, please use the latest version of the editor:


Martin Evans (Unknown) 01.10.2017 18:10
hi giants software

whitch graphics card would be good to get to edit a map. I ge the message cant open gl viewport


William Smithson (Unknown) 16.11.2017 04:12
can you change the open gl

Houben Wim (Willem234) 17.11.2017 17:28

I got the same problem.
My PC crashed, I restarted it and since then I can't open the editor.
I deleted ALL the files around the editor and reinstalled it.
But the same window occured; 'Can't load xml config file: C:/Users/User/AppData/Local/GIANTS Editor 64bit 7.1.0/editor.xml'.
For info; my graphic card is strong enough to support the editor.

Bartek Perkowski (Unknown) 17.11.2017 17:41
Also I've the same problem: I have been editing my map and creating objects and then suddenly there is the same problem. Gaints 7.0.5 works normal
In %appdata% I haven't this folder which is mentioned in error... But maybe someone who has this folder could send it to mega/google drive and send link to download it, I think that It could help ;)

Houben Wim (Willem234) 17.11.2017 19:09
I downloaded the GIANTS EDITOR version 7.0.5 and it worked(for now)

Rob Van Den Berg (thudge) 17.11.2017 22:19
Hi Ross, Wim

you both specifically mentioned folder "C:/Users/User"...etc. Just curious. Did you both literally chose Windows username "User", or did you both happen to choose to replace your own username in the message above ?
The editor config filename would typically be found at C:/Users/[User]/AppData/Local/GIANTS Editor 64bit 7.1.0/editor.xml, with [User] replaced by your Windows username. Do you agree Emil?


Dirk Kuiper (Unknown) 13.01.2018 14:12

I installed the editor on a new MAC Pro in a Windows environment White Paralles software.
Im getting a different error. says 'Could not create OpenGL viewport'
Now i reed graphics card is not powerful enough to run the Editor.

I have a Radeon Pro Vega 56 8 GB
in Paralles I have set the settings to a maximum of 2 GB
Sombody a solution???

Tim Straughn (RoadRoach) 14.01.2018 19:41
I loaded FS2017 Platinum from purchased disc (mind you two copies for two identical machines so the wife and I could use Multiplayer mode), and everything worked, including GE, but of course, the package started ranting about updates as soon as I started it the first time. So, updates I did (which are flagged by Win10 about bad signature files). First attempt, not so good. Second, not much better, but a bit of finagling, figuring out which way to hold my tongue, which foot to stand on, etc, etc. I finally got it to work and am now running the patched FS17. Or did it? Prior to the updates (patches) the editor worked seemingly just fine(though I didn't actually edit anything with it), and I even loaded the demo map to have a quick look at what can be done. After the patches "Could not create OpenGL viewport". So, what this is telling me, is that my graphics adapter WAS good enough for the distributed version, but not after the update? That's the only conclusion I can make, but I don't see any update notice (or option to eliminate the nag screens about the updates) that says that the update (patch) will kill the editor on my hardware. So your solution is for me to go out and buy new hardware? Ummm, I think not. I would urge you to reconsider that the problem just might not be the hardware and stop spouting that as a standard answer. You're sounding like corporate America when you do. "Not my fault" is what I hear from my grandchildren, but expect a bit better from someone I give money to for something I want to use. I would urge some sort of hardware testing routine or something built into the updates to indicate that the update may not be compatible with the existing hardware. I can take that kind of rejection a lot better than software that just quits working after an update.

The canned answer of "your old computer is junk" is a VERY bad response to the questions that many have, yet very indicative of the answers from 20-somethings and 30-somethings. Not all of us can justify running out to buy $250 worth of graphics adapter for a game. G3 should probably consider the Dale Carnegie School of Tact for it's employees and support team, and even more consider figuring out what they broke with the update and at least send out an advisory to their registered users that the patch is not compatible with some legacy hardware that the prior version WAS compatible with. It's the nice thing to do, and gives the customers the option of not upgrading if they're actually using the tools. Had I known about this potential in advance, I might not have upgraded as I have no intention of ever posting a mod for other's consumption. But it might be nice to do some things that my wife and I will enjoy. I don't have this option now, and just because FS2017 Editor doesn't want to work on my PCs, that is not a valid reason to go spend up to 20x the cost of the game for a new system, not to mention the hassles of transferring all my software and apps to the new machine. I bought the game as an amusement, not a money pit.

I tend to believe that some component of the Editor is not compatible with Win10-64 bit, or for those of us that prefer secure machines, something in Windows Defender may have blocked a file update for something Windows feels they can do better/safer because of the file signature issue. I'm at the end of my hardware's support, but not yet ready to replace it, and something that works on it once should continue to work on it. Windows did not change, neither did my hardware. FS017 DID. I'll give you three guesses what I suspect to be the culprit, and the first two don't count.

Johnny Ray Thompson (Akecheta_Wakan) 22.10.2018 17:54
So Deleted all Giants files, uninstalled, reinstalled, cant load xml either, how ever Giants editor game edition will load, but there is no fruits in Terrain Edit, this is weird, not to mention entire map is masked with pig mud

Note: Log in to post. Create a new account here.