Community Forum

Giants Editor 7.1.0 stopped working

Forum Overview >> Editor

Created01.11.2017 19:20

Gabi Barbus (Unknown) 01.11.2017 19:20
So last night i was working at the map, and the only things i did was to duplicate some houses and after that i've edited some terrain and terrain texture, i've saved the map, closed the program and then i entered the game to check the things i've made. I saw that the map was loading really slow and after that it crashed with the error "giants engine 7.0.0. has stopped working" . Then i wanted to open the map in the editor to see if there are any errors and when the editor was loading it crashed with the error "giants editor 7.1.0. has stopped working"....i've checked the log file of the editor and the game log file and it didn't showed any errors. I've made a clean install of the editor and it does the same thing. Then i searched for almost an hour for solutions and nothing...
Editor log file:
Game log file:
In the game log file, there are 3 errors, and with those errors it worked from the begging.
My last thought is: there is a limit of objects that giants editor supports?

Gabi Barbus (Unknown) 03.11.2017 12:53
Update: I archived the map folder to .zip format and from the editor i hit open mod and after it unpacked the map and started to load it, it didn't crash the program nor load the map, and it left me with these 3 errors:

Error: Hidden files are not allowed 'LeereMap_LS17/maps/prefabs/Zaun_Pack_V2/Bauzaun_V1.0/Texturen/Thumbs.db'
.Error: Hidden files are not allowed 'LeereMap_LS17/maps/prefabs/Zaun_Pack_V2/ZaunModern_V1.0/Thumbs.db'
.Error: Failed to open xml file 'C:/Users/NOXNOVA/Desktop/LeereMap_LS17/modDesc.xml'.

In the both .../Texturen/ folder, there is no hidden file under the format .db wich i've never heard about, and there are no other hidden files at all.
And the last error, how can i solve it?

Gabi Barbus (Unknown) 05.11.2017 18:28
Update: I haven't try anything for solving the problem in the past 2 days, i let it like that, now i wanted to check if any miracle has arrived to solve my problem and now after crashing it tells me this:
I don't understand, why form day tot day it tells me something else without even touching the map or the files, even without booting up my laptoooop....

Gabi Barbus (Unknown) 15.11.2017 11:55
So i guess that nobody knows what caused this error? Cuz i don't wanna rebuild it from my latest backup and when i will be up to date, it will give me this error again...

Rob Van Den Berg (thudge) 15.11.2017 13:24
I sure don't know what caused the error. I'm sure you can google information on the 'Thumbs.db', it will tell you something like "These files are generated automatically by Windows so that folder content doesn't need to be recalculated every time the folder is viewed". You can turn that off, instructions depending on your Windows version.
I'm also sure you verified the location and correctness of the modDesc.xml file.
I interpret the ...shape not found... messages as corruption or even lack off .shapes files.
Rebuilding from your latest backup does seem to be your best bet.

Gabi Barbus (Unknown) 28.11.2017 20:16
Thanks, I solved all the other problems, and I started rebuilding.
But what do you mean by "lack of .shapes files"? that I reached the limit of objects that GE supports?

Houben Wim (Willem234) 14.12.2017 12:04
Still not working

Note: Log in to post. Create a new account here.