Community Forum

"Error: Failed to copy file" while exporting an i3d file

Forum Overview >> Editor

Created29.06.2018 22:08

Alex Montgomery (Unknown) 29.06.2018 22:08
I am trying to export the caseIH130 Series to a different folder to make it into a mod. I have created custom colors and want to have it available in the store to purchase as a mod. When exporting the i3d file I get a Error: Failed to copy file for all of the files in the shared folder and shaders folder linked to this i3d. Any ideas on what is causing this error and how to fix it?


Bilbo Beutlin (BBeutlin) 29.06.2018 23:13
most common problems:
- the GE doesn't have permission to write to the selected folder (due to Win UAC)
- the files or folders exist already and are write protected
- the file path/name contains non-ASCII characters or spaces
- the destination folder is on non-standard drive, eg. webspace like OneDrive

Alex Montgomery (Unknown) 02.07.2018 15:50
I looked at every option you put down and corrected as needed and it still gives me an error. Any other suggestions or information you need?

Bilbo Beutlin (BBeutlin) 02.07.2018 20:25
Try this:
Create a folder "C:\FS17temp" and export the mod to this folder.

If it doesn't work, the GE doesn't know from where to copy the files. Then your game install was faulty (missing entries in registry). Re-install the game by right click on the Setup and "run as administrator".

Alex Montgomery (Unknown) 09.07.2018 22:51
I re-installed the game and got the same error trying to export the i3d file. Any other suggestions Bilbo?

Bilbo Beutlin (BBeutlin) 10.07.2018 14:38
Which "Item" did you select when exporting as "new mod from game"?

Did you test whether "export all with files" works? (instead "new mod ..")

Is it only for this i3d? or does it happen also with others?

Alex Montgomery (Unknown) 10.07.2018 15:28
I apologize for not seeing that option sooner. The "new mod from game" option worked! What I was doing was exporting all with files. With the "new mod from game" option it copied everything except for the store_caseIH130Series.png, which isn't a problem. Thank you for the help!

Note: Log in to post. Create a new account here.