Community Forum

4X map FPS Frame Grab

Forum Overview >> Editor

CategoryEditor
Created11.12.2018 03:48


William Rowe (Bonger76) 11.12.2018 03:48
I ask about this in 16xRIP post ,but need to see if anyone else is having the same problem on thier 4X map when havesting ,mowing,spreading fert,plow and cultivating .I get a FPS 60 to 53 fast and the screen grabs like its loading every half second,its not a graphics thing it has somthing to do
withwhen harvesting the crops and changing the ground.it happens with the grass tendder and windrower and baler to.I compered my map with giants map all same but the wieghts .gdm and .grle ,and thier are no errors in the log.

Thanks

Orval Hilliard (sixgun) 11.12.2018 10:04
I have the same problem on my 4x map. It would be nice to have some in put from Giants.

F Thomas (theGerman) 11.12.2018 12:03
It grieves me to hear that your performance has problems with your map. I myself have a 16X and 4X. At the moment I am working the 16X for the LS 19. It took me hours to clear the log. If you have not achieved that yet, that should be your next target for now. It is still an early stage, because the LS 19 has not yet received its final patch. So enough time to edit his map. However, my experience has been that the LS 19 does not work well with old ground textures, so I completely redesign my map with the LS 19 textures. Also all .wav sound files are replaced by .ogg files.


Bilbo Beutlin (BBeutlin) 11.12.2018 15:57
Just a hint, perhaps it helps someone:
I've read variously that a map causes problems (just the multi sized) if a water plane is missing. It may lead to bad performance upto occasional crashes.

William Rowe (Bonger76) 11.12.2018 17:42
Everything is 19 just used my map_ dem and objects from 17,I got eveything working sell points, silos , placeables good FPS all works good drive all
around map no lag,just when as stated above any farming.
If some has a 4X and dont have this problem,mabey you could show us how your map folder is set up.It acts like a loading issue mabey a file path is
set wrong,it may work no errors but causes the lag.When I reduce the FPS to 30 it slows down the time of lag when unlock the FPS it speeds up the time of the lag.
I have tried everything I can like of compared my map .i3d to 19maps,next thing i willtry is to just make thier map a 4X,see if that work.


Dasgfsdf Agfdf (rhshsfgsg) 11.12.2018 20:39
I have the same problem.
But sadly no solution.

Krists U (Kristsu) 11.12.2018 23:22
I create empty x16 map and tested it step by step. This fps freezes started when i resize resolution in file "map.i3d.colMap.grle"
I really hope that Giants will help find a solution, otherwise there will not be a lot of good maps.


William Rowe (Bonger76) 12.12.2018 05:02
This is what I did and fix the problem don't know haven't fully tested all parts ,the missions work no FPS lag,For my 4X map whent back to the
wieghts,.gdm,.grle, where in FS17 for a 4X map

wieghts2048x2048 I did go back and run it with the wieghts 4096x4096 and got a little lag not to bad
.gdm 4096x4096
.gle2048x2048
map_dem 2049x2094
pda_map_H 4096x4096
and in map_.xml pda 4096x4096

with the 16X you might try changing you .gdms to 8192x8192 I'm that that fare with my 16X map convertion to test that.

remember after you reduce your .gdm make shure to run the groundColision script in editor.I will keep testing and If anyone sees that this might cause a problem please thet us know



William Rowe (Bonger76) 13.12.2018 00:27
So fare the onley problem is the paint is more blocky that is probely why they uped thier wieghts to get tighter detail,but it is like that is the limit make the wieghts any bigger then 2048x2048 and you get that lag,I dont know if thier is any thing that need to be changed in the .i3d or in editor or this is the end of big maps,still have the problem like in 17 the longer you play the FPS get slow and slower,hired help really drops FPS if you have more then 1.
If anyone know if thier is a Limit to the map size that the game can handle.


Orval Hilliard (sixgun) 13.12.2018 06:17
William Rowe

You were right about putting the texture size back to what they were in 17. I can play on my map with no lag now. Thanks for the help

F Thomas (theGerman) 13.12.2018 11:13
Like any other program, the LS requires precise work. This is even more important for large maps. Errors are punished with losses of the Performence up to the program demolition. The fact that the possible size of the maps was limited with the LS 19 is not known. Only the existing hardware will limit the size.

Dasgfsdf Agfdf (rhshsfgsg) 13.12.2018 17:36
I get the lags if I'm in a vehicle and look to the point where the sun rise.

William Rowe (Bonger76) 14.12.2018 02:22
Work at this all day ,and my best guess it is the ground or terrian shader or bolth,don't know anything about shader edit ,with the wiehgts and .gdm for a 4Xmap like we had in FS17 is how they have the game maps wieghts and .gdm set up that is why thier is no lag with the 4X map set up like in FS17 but the wieght are a real pain to paint big and blocky,with the 16X have not tried but even with your wieghts at 4096x4096 you should have
that repeatitive lag.

Dasgfsdf Agfdf ,that is usely to many objects in that direction and to much for your system, had same with my map to many trees fix with new card more ram.The lag with the bigger maps is not just a FPS drop wich is only like a10FPS drop it is the screen freezes repeatitively every second.Hope that some smarter then me can help so we can get the wieghts bigger for the detail.

Petr Lederer (Ledik) 14.12.2018 20:58
i make this export all trees in one i3d.open in notepad++ and animation wind stop :<CustomParameter name="windScale" value="0 0 0 0"/>
save this i3d.Delete all trees in map in GE.Import modified i3d trees.
try it

William Rowe (Bonger76) 15.12.2018 22:14
Didn't help acualy made my FPS worse,still think it is a shader terrain or ground

Joe Lindberg (lindbejb) 15.12.2018 23:05
does it when only terrain is in map, nothing else.

William Rowe (Bonger76) 15.12.2018 23:46
They might have limited the terrain size if it happens when your in a vehicle they where having FPS problem when in outside of cab camera I don't know this is something Giants would have to answer.I still think it has to do with the shader.I stop working on converting over my 16X map because
game is having problem with the 4X otherwise I would be helping you and testing along with you.

Petr Lederer (Ledik) 16.12.2018 11:01
I do not have a problem with FPS on the 4x4 map, it will not fall below 30 for 8 players.
I have a problem with grass when I want to make dried grass. see photo
https://imgur.com/a/J9pppKp

F Thomas (theGerman) 16.12.2018 12:04
When editing my 16X and the tests, I can not yet determine these FPS problems that others report. What I've noticed so far, however, is that the traffic only on 2 or three of the 11 splines that are on the map, drives. On the 17 map there were no problems. I will continue to convert my map and closely follow the reports here and my tests. Giants is still working on the FS 19. If this work is completed, and then imagine that large maps are no longer possible, that would be a bitter blow against the FS. My interest would suddenly approach zero.

Cole Johnson (cwj108) 16.12.2018 16:33
Im having issues at the eastern border for 4x and 16x. On the western side it works fine, if I drive to the eastern border and look out, it freezes up unless I get out of the vehicle


William Rowe (Bonger76) 16.12.2018 16:43
Petr, from the photo it looks like a tipcollision problem check your info layer in GE ,the tender when produceing drygrass hit the tip colision stores up the drygrass then once it passes the collision it dump out a big pile of the stored up drygrass.

If you have your wieghts and .gdms set up like they were FS17 you whont have the FPS frame grab,the problem I have with the wieghts set at this size the details or blocky and I like the ground markers on the seeders with the waight like they were in FS17 it leaves 3 plowed furoes,and whant to convert my 16X map but if you can't have weights bigger then 2048x2048 then not mutch point the wieght would be way to blocky.

FThomas, try working the ground harvesting ,planting ,fertilizing and see if you have any fram grab watch your tires and look down on the tractor and wath the ground.

F Thomas (theGerman) 17.12.2018 12:37
Bonger76, my tests are negative in this respect, with me no frame drops are detectable.


Krists U (Kristsu) 17.12.2018 12:53
F Thomas, what is the resolution of your ........._weight.png and map.i3d.colMap.grle files?

William Rowe (Bonger76) 17.12.2018 18:31
what are your sizes,I have tried every size combonation can think of and still get PSF and frame grab,when the wieght and .gdm are bigger then giants for the 4X map I tried these wich took hours and hours because now thiers is 60 wieght.png,

wiehts 4096x4096
.gdm 8192x8192
tipcol 2048x2048

wiehts 4096x4096
.gdm 8192x8192
tipcol 4096x4096

wiehts 4096x4096
.gdm 8192x8192
tipcol 8192x8192

wiehts 4096x4096
.gdm 4096x4096
tipcol 2048x2048

wiehts 4096x4096
.gdm 4096x4096
tipcol 4096x4096

the only thing that works ithe frame grabe when working is,

wiehts2048x2048
.gdm 4096x4096
tipcol 2048x2048
the FPS is not realy the problem its that frame grabe when working that is the only time I have a problem

Petr Lederer (Ledik) 18.12.2018 08:06
I have problem whit grass and dry grass up in topic its foto.
And resolution in this map its 4x4 and full edit.
Whem I change size fruit_density up 8192 all fruits change canal: deco grass its maize ,maize its sobyen and this its omg :-D.

and size its
wiehts 4096x4096
.gdm 4096x4096
tipcol 2048x2048

Krists U (Kristsu) 18.12.2018 08:34
Petr, try another picture editor to resize your files resolution.

Petr Lederer (Ledik) 18.12.2018 14:57
yeah now its funkction thanks size its :
wiehts 4096x4096
.gdm 8192x8192
tipcol 2048x2048
and me make problems in map 4x4 backdrop.Whem look up or north south west fps go rapid down under 10 fps.
I must delete this obejct
Very thanks for help

Petr Lederer (Ledik) 21.12.2018 14:38
And in option advenc option make MSAA off total off .fps no grab .

I have problem in original make this msaa off no problem game runing smoothly



Orval Hilliard (sixgun) 22.12.2018 05:07
Giants needs to fix the problem with the water plains. I am still having problems with frame grab even with their water planes.

Bilbo Beutlin (BBeutlin) 22.12.2018 05:37
Waterplanes have always highest priority - followed by the mirrors.
I think all would agree - or would one like to have all mirrors functional, but an empty river/lake? *g*
Some game calculations are obviously bound to the presence of at least ONE waterplane.

The difficulties appear obviously, if the game engine has to distribute the present "mirrors" to the map and vehicle sources. This may lead to "priority conflicts" and extensive switching and resulting lags.

Try in game settings different amount of mirrors and you'll see a difference in FPS and lags.

If there are no faulty density map setups, the "frame grab" issue is minor caused by map size, but by game's mirror settings and certainly by system performance.
(my experiences)

William Rowe (Bonger76) 22.12.2018 20:23
Orval it has to do with the direct11 if you dont minde lower FPS go to game.xml and change <renderer>D3D_11</renderer> to <renderer>OpenGL</renderer> and that minor frame grapb that gives me motion sickness is gone but the FPS drop I still haven't heard anything from
Giants on this

Cole Johnson (cwj108) 28.12.2018 04:03
I still cant figure this out. Ive tried turning off MSAA, tried changing the renderer, the weight sizes. I still get the noticeable 3-4 fps frame grab only when working ground. Very frustrating

William Rowe (Bonger76) 29.12.2018 04:27
YA I gave up whent back to FS17, it is something Giants has not fixed ,the graphics for the PC are not working right thier to busy with PlayStation they have already made two more patches for them $$$$ea$$$onPA$$$$$$,They will fix it just in time to start this crazy cycle over again.



Note: Log in to post. Create a new account here.