Community Forum

Giants editor has stopped working

Forum Overview >> Editor

Created10.01.2019 06:33

Michael Tulloch (asian) 10.01.2019 06:33
I have recently been starting to make a map for myself, and my friend to use for MP. I started a couple days ago, and all was good until I tried to open it today. I looked in my editor_log.txt and found this:

GIANTS Engine Runtime 8.0.0 (17942) 64bit (Build Date: Nov 30 2018)
Copyright (c) 2008-2018, GIANTS Software GmbH (, All Rights Reserved.
Copyright (c) 2003-2018, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 8.1.0
Main System
CPU: Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz
Memory: 8149 MB
OS: Windows NT 10.0 64-bit
Physics System
Version: 5.9.5
Thread(s): 2
Audio System
Driver: SoftMixer WASAPI Stereo
Version: 2018.11
Frequency: 44100
Max. active sources: 256
Render System
Driver: OpenGL
Card Vendor: NVIDIA Corporation
Renderer: GeForce GTX 1060 3GB/PCIe/SSE2
Version: 4.5.0 NVIDIA 417.35
Shader Version: 4.50 NVIDIA
Max. Texture Layers: 16
GL_AMD_depth_clamp_separate not supported
Started 2 threads for threadpool 'Render threadpool'
Hardware Profile
Level: Very High (forced)
View Distance Factor: 1.300000
Shadow Quality: 2.000000 Base-Size: 2048 Filter-Size: 16 Shadow Focus Box true
Shader Quality: 3
Skip Mipmaps: 0
LOD Distance Factor: 1.300000
Terrain LOD Distance Factor: 2.000000
Terrain Normal Mapping: Yes
Foliage View Distance Factor: 1.600000
Volume Mesh Tessellation Factor: 0.750000
Tyre Tracks Segments Factor: 4.000000
Max. Number of Shadow Lights: 5
Max. Number of Lights: 512
Max. Number of Lights Per Cluster: 32
Bloom Quality: 5
SSAO Quality: 15
DOF: Enabled
Cloud Quality: 4
Error: Failed to open xml file 'C:/Users/User/Desktop/BlankMap_BlurModding/maps/../../../../../../Desktop/New folder (6)/New folder (2)/FS19_Empty_Map9/shaders/fxCircleShader.xml'.
Error: Can't load resource 'C:/Users/User/Desktop/BlankMap_BlurModding/oxford19/clover creek/Import/Houses/HouseChimneySmoke1/IDAHO/suburbs/suburbs_alpha.png'.
Error: Can't load resource 'C:/Users/User/Desktop/BlankMap_BlurModding/oxford19/clover creek/Import/Houses/HouseChimneySmoke1/IDAHO/suburbs/suburbs1_diffuse.png'.
Error: Can't load resource 'C:/Users/User/Desktop/BlankMap_BlurModding/oxford19/clover creek/Import/Houses/HouseChimneySmoke1/IDAHO/suburbs/suburbs_normal.png'.
Error: Can't load resource 'C:/Users/User/Desktop/BlankMap_BlurModding/oxford19/clover creek/Import/Houses/HouseChimneySmoke1/IDAHO/suburbs/suburbs_specular.png'.
Error: Failed to open xml file 'C:/Users/User/Desktop/BlankMap_BlurModding/oxford19/clover creek/Import/Houses/particleSystems/particleSystemShader.xml'.
Error: Can't load resource 'C:/Users/User/Desktop/BlankMap_BlurModding/oxford19/clover creek/Import/Houses/HouseChimneySmoke1/02Gebaeude/Grill/smokeParticle.png'.
C:\Users\User\Desktop\BlankMap_BlurModding\maps\mapDE.i3d (605.85 ms)
Check for updates (
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/wheat.i3d (10.85 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/grassDense.i3d (15.24 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/canola.i3d (8.92 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/barley.i3d (20.23 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/maize.i3d (12.52 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/decoFoliage.i3d (37.41 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/potato.i3d (7.89 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/potatoHaulm.i3d (2.00 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/sugarbeet.i3d (5.54 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/sugarbeetHaulm.i3d (1.39 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/sunflower.i3d (12.65 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/soybean.i3d (6.66 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/oilseedRadish.i3d (1.96 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/poplar.i3d (11.12 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/bush01.i3d (19.81 ms)
Info: transform group 'bush01' has elements very far out from the cell edge (29.61% expansion)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/oat.i3d (7.44 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/sugarCane.i3d (10.37 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/sugarCaneHaulm.i3d (1.63 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/cotton.i3d (8.01 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/weed.i3d (10.95 ms)

I deleted the 'clovercreek' file location, but it still wouldn't open. Any help would greatly be appreciated.


Bilbo Beutlin (BBeutlin) 10.01.2019 08:04
You must edit manually the <Files> pathes in map.i3d for the files which couldn't be loaded.

Michael Tulloch (asian) 10.01.2019 22:32
Where would I find that? Can you give me a file directory pathway to the files? I tried looking for it and can’t find where I need to go.

James Biddulph (Unknown) 10.01.2019 22:47
You need to open the i3d file in a text editor program (I recommend notepad++) the files mentioned are at the top of the file they are inbetween the codes
and look something like
<File fileId="12" filename=""/>
these are the files they are talking about, you need to point it to where the actual file is located, if it is a game file put $data/ in front of the loaction that will tell the i3d file to go to the game files data folder and look in there so for instance the file
Farming Simulator 19/data/foliage/wheat.i3d
needss to be changed to
<File fileId="24" filename="$data/foliage/wheat.i3d"/> (change the number to suit yours)
I am sure this is correct, Giants will correct me if I am wrong.

Michael Tulloch (asian) 10.01.2019 23:02
Ok thanks. I’ll look into that when I get home.

Michael Tulloch (asian) 11.01.2019 00:07
I have found the file location in the i3d file using Notepad++. What do I do from here?

Note: Log in to post. Create a new account here.