Community Forum

Giants Editor wont start

Forum Overview >> Editor

Created25.12.2019 22:02

Trayven Bagley (caseihbagley) 25.12.2019 22:02
I downloaded the Giants software to work with Farm Simulator 19 but it wont start. I had Farm simulator 15 and it had an old editor. I installed the new editor then I uniinstalled the old editor thinking it might be what was making the v8 not work. I can't find any logs or anything to get any error message it just brings up the window and says starting on the top of the window and then it closes.
Running windows 10 64bit, AMD A6-3620 APU with Radeon HD graphics with 6 gigs of ram

Gtx | Andy (GtX_Andy) 26.12.2019 01:18
GE log file is located at the following location
C:\Users\[USERNAME]\AppData\Local\GIANTS Editor 64bit 8.1.0

Chris Comp (Chrisc224) 31.12.2019 19:20
Wont work for me Neither so your not alone

Chris Comp (Chrisc224) 31.12.2019 19:21
Wont work for me Neither so your not alone

Thomas Ellwood (Unknown) 02.01.2020 01:56
same for me wont load nothing

Shadwik Benoit (benoitsk218) 02.01.2020 20:05
im having the same problem here to

Randy Hansel (PlanetRandy) 06.01.2020 20:37
It crashes stating I don't have OpenGL Version 4.5
My system DOES have 4.5

Giants will NEVER fix this because they don't care.

Christopher Lubbers (TechAntidote) 11.01.2020 12:34
Hey if anyone figures this out please POST! Editor worked fine for me up until yesterday checked logs to make sure all was good. not sure what is going on here it wont open at all for me i click to open it then it just sits in the taskbar wont open! LOG

GIANTS Engine Runtime 8.0.0 (18339) 64bit (Build Date: Feb 9 2019)
Copyright (c) 2008-2019, GIANTS Software GmbH (, All Rights Reserved.
Copyright (c) 2003-2019, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 8.1.0
Main System
CPU: AMD FX(tm)-8350 Eight-Core Processor
Memory: 8164 MB
OS: Windows NT 6.1 64-bit
Physics System
Version: 5.9.5
Thread(s): 2
Audio System
Driver: SoftMixer WASAPI Stereo
Version: 2018.11
Frequency: 48000
Max. active sources: 256
Check for updates (
Render System
Driver: OpenGL
Card Vendor: ATI Technologies Inc.
Renderer: Radeon RX 570 Series
Version: 4.5.13586 Core Profile Context 20.1.1 26.20.15011.5007
Shader Version: 4.60
Max. Texture Layers: 16
Started 3 threads for threadpool 'Render threadpool'
Hardware Profile
Level: High (forced)
View Distance Factor: 1.100000
Shadow Quality: 1.000000 Base-Size: 2048 Filter-Size: 16 Shadow Focus Box false
Shader Quality: 2
Skip Mipmaps: 0
LOD Distance Factor: 1.100000
Terrain LOD Distance Factor: 1.500000
Terrain Normal Mapping: Yes
Foliage View Distance Factor: 1.400000
Volume Mesh Tessellation Factor: 0.850000
Tyre Tracks Segments Factor: 2.000000
Max. Number of Shadow Lights: 3
Max. Number of Lights: 512
Max. Number of Lights Per Cluster: 32
Bloom Quality: 4
SSAO Quality: 12
DOF: Enabled
Cloud Quality: 3

Bilbo Beutlin (BBeutlin) 11.01.2020 22:50
Delete in folder "{USER}\AppData\Local\GIANTS Editor ...\" the file "editor.xml" and all files in folder "shader_cache".
Make sure all GE relevant files are on local drives, don't use cloud storage.
At first test by opening a default i3d from game.

Christopher Lubbers (TechAntidote) 12.01.2020 11:23
Thank you Bilbo Beutlin that worked for me i appreciate your reply!

Note: Log in to post. Create a new account here.