Community Forum

Vehicles can drive under water

Forum Overview >> Editor

Created15.03.2020 10:52

Claudio Valett (scud1984) 15.03.2020 10:52

i tried to fix some issues on the 4x Map "FlusstalV2" for use on our private Server and found a problem i cant solve myself.
All vehicles can drive under water. No dronwing, no message.

The waterplane has both attributes:
<Attribute name="onCreate" type="scriptCallback" value="Environment.onCreateWater"/>
<Attribute name="isMainWater" type="boolean" value="true"/>

Anyone has an idea how to fix this?

Bilbo Beutlin (BBeutlin) 15.03.2020 14:18
I'd guess, a mod causes this.
Take out all mods (except the map) and try again.

Claudio Valett (scud1984) 15.03.2020 15:21
Done, but problem still exists. Without mods (except the map) my vehicles can still drive under water.

Bilbo Beutlin (BBeutlin) 15.03.2020 17:23
Curious. Normally you get the warning "don't drive into water" and the vehicle stops.

So I'd guess it's intended by the map. The name "Flusstal" (river valley) looks suspicious concerning this behaviour. ;)
Mayby the author has disengaged the water warning in the mission.lua or extra script.

For further questions contact the author.

Claudio Valett (scud1984) 15.03.2020 19:35
i've allready checked that. No extra scripts and vanilla mission.lua (from game-dir).

I've contacted the author 4 weeks ago, but no reply. (i think he dont mod anymore)
So it is up to me/us to fix this problem ;-)

Bilbo Beutlin (BBeutlin) 15.03.2020 22:07
Is the main waterplane somehow transformed?
Translations don't matter (usually), but rotations or scaling can cause failures.
If so, normalize (freeze) this transformations.

Claudio Valett (scud1984) 17.03.2020 07:41
No, but i've nomalized it and tried again. Same as before.
Can a watershader (there is a shader for riverwater) break this game mechanic?

Bilbo Beutlin (BBeutlin) 17.03.2020 12:33
I don't think so. But try out.

What you also could try: all the default maps have 'mirror' waterplanes. Perhaps these are effective somehow in this issue.

Claudio Valett (scud1984) 18.03.2020 17:35
OK, i fixed it. I've imported a Waterplane from another 4x map and now it works.
Thanks Bilbo for your assistance :)

Note: Log in to post. Create a new account here.