Community Forum

Giant Editor isn't running (inactive)

Forum Overview >> Editor

CategoryEditor
Created17.04.2020 18:01


Thomas Müller (Unknown) 17.04.2020 18:01
Hey Guys,

yesterday i did some work on the Giant Editor. After Finisching I closed the G and shut down my PC.

Today i want to go on with my work. But it isn't posible.
The GE is starting but i can only see the Icon of it in the Taskbar.

Thats the COntent of the GE log:

GIANTS Engine Runtime 8.0.0 (19543) 64bit (Build Date: Jul 3 2019)
Copyright (c) 2008-2019, GIANTS Software GmbH (giants-software.com), All Rights Reserved.
Copyright (c) 2003-2019, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 8.2.0
Main System
CPU: Intel(R) Core(TM) i7-4720HQ CPU @ 2.60GHz
Memory: 8104 MB
OS: Windows NT 10.0 64-bit
Physics System
Version: 5.9.5
Thread(s): 2
Audio System
Driver: SoftMixer WASAPI Stereo
Version: 2018.11
Frequency: 48000
Max. active sources: 256
Render System
Driver: OpenGL
Card Vendor: ATI Technologies Inc.
Renderer: AMD Radeon R9 M200X Series
Version: 4.5.13587 Core Profile Context 20.3.1 26.20.15029.15007
Shader Version: 4.60
Max. Texture Layers: 16
Started 3 threads for threadpool 'Render threadpool'
Hardware Profile
Level: Medium (forced)
View Distance Factor: 1.000000
Shadow Quality: 1.000000 Base-Size: 2048 Filter-Size: 4 Shadow Focus Box false
Shader Quality: 1
Skip Mipmaps: 1
LOD Distance Factor: 1.000000
Terrain LOD Distance Factor: 1.000000
Terrain Normal Mapping: Yes
Foliage View Distance Factor: 1.000000
Volume Mesh Tessellation Factor: 1.000000
Tyre Tracks Segments Factor: 1.000000
Max. Number of Shadow Lights: 1
Max. Number of Lights: 512
Max. Number of Lights Per Cluster: 32
MSAA: 1
Bloom Quality: 3
SSAO Quality: 8
DOF: Disabled
Cloud Quality: 2
EnvMap Blending: Enabled
Check for updates (https://gdn.giants-software.com)
Warning: Mod-List download failed... retry in 2.000041 s. 0 trail

I tried to uninstall and reinstall it, but no improvement

Could anybody help?

Bilbo Beutlin (BBeutlin) 17.04.2020 20:26
Happens sometimes after major gfx changes or Windows updates.

Delete the file "C:\Users\USER\AppData\Local\GIANTS Editor 64bit 8.2.0\editor.xml".
Might also be helpful to delete the content of the folder "shader_cache".

Also do NOT use cloud storage (like OneDrive) for GE related files. Due to enhanced access times this can lead to read errors.
Be sure to have the files all on local drives.

Thomas Müller (Unknown) 17.04.2020 20:53
hey Bilbo,

thx for your tipp. That was helpful.

nice Evening

Andoni Cano Chamizo (Andoni) 18.04.2020 17:35
I don't know why I open the GIANTS Editor and it closes me alone. I have installed it 5 times previous versions and it doesn't work for me. I have a Windows 10.


Bilbo Beutlin (BBeutlin) 18.04.2020 22:43
And what do you think we should do without more information? No one here is clairvoyant.
We need at least the editor log file: {USER}\AppData\Local\GIANTS Editor ...\editor_log.txt
Case this doesn't exist, there's something wrong with your system.


Note: Log in to post. Create a new account here.