Community Forum

Map suddenly wont open, no erros

Forum Overview >> Editor

Created03.06.2020 10:11

Doug Williams (Dougw133) 03.06.2020 10:11
I've been working on a map for ages. A lot of work. I do make backups but haven't in a few days because I wasn't doing anything big.

Today I was adding some onCreate callbacks for the Seasons Admirer script. I was testing iceplanes loading with proper collision and everything was fine. Then I applied the script callback to a particle emitter. I went into game to test and it crashed to desktop. I thought that was odd so I went to the editor to undo what I did. It loaded fine, I undid my last work and saved it. Tried to load the game and it crashed...Then back to the editor crashes and wont open my map. This doesn't make any sense. Usually it would just be an error. So I went into the i3d in xml editor and removed all the onCreate callback I made. Still won't work. I didnt change anything but in the editor itself. I have been pulling my hair out for hours trying to recover. The odd thing is that a backup from two days also won't work when I bring all files into the folder of my backup. A backup from a week ago does work...But that is so far back from all the work i've done. Any idea what could have possibly gone wrong? I retraced my steps undoing everything I could think of, things that shouldn't matter.

There are no errors in the log.

GIANTS Engine Runtime 8.0.0 (19543) 64bit (Build Date: Jul 3 2019)
Copyright (c) 2008-2019, GIANTS Software GmbH (, All Rights Reserved.
Copyright (c) 2003-2019, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 8.2.0
Main System
CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
Memory: 32702 MB
OS: Windows NT 10.0 64-bit
Physics System
Version: 5.9.5
Thread(s): 2
Audio System
Driver: SoftMixer WASAPI 7.1 Surround
Version: 2018.11
Frequency: 44100
Max. active sources: 256
Render System
Driver: OpenGL
Card Vendor: NVIDIA Corporation
Renderer: GeForce GTX 1080 Ti/PCIe/SSE2
Version: 4.5.0 NVIDIA 445.87
Shader Version: 4.50 NVIDIA
Max. Texture Layers: 16
GL_AMD_depth_clamp_separate not supported
Started 3 threads for threadpool 'Render threadpool'
Hardware Profile
Level: Very High (forced)
View Distance Factor: 1.300000
Shadow Quality: 2.000000 Base-Size: 2048 Filter-Size: 16 Shadow Focus Box true
Shader Quality: 3
Skip Mipmaps: 0
LOD Distance Factor: 1.300000
Terrain LOD Distance Factor: 2.000000
Terrain Normal Mapping: Yes
Foliage View Distance Factor: 1.600000
Volume Mesh Tessellation Factor: 0.750000
Tyre Tracks Segments Factor: 4.000000
Max. Number of Shadow Lights: 5
Max. Number of Lights: 512
Max. Number of Lights Per Cluster: 32
Bloom Quality: 5
SSAO Quality: 15
DOF: Enabled
Cloud Quality: 4
EnvMap Blending: Enabled
Check for updates (
C:\Users\Doug\Documents\My Games\FarmingSimulator2019\mods\FS19_DELTA\maps\mapDelta_Junction.i3d (5344.95 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/wheat.i3d (7.12 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/grassDense.i3d (3.90 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/canola.i3d (4.39 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/poplar.i3d (8.23 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/barley.i3d (2.92 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/maize.i3d (8.45 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/decoFoliage.i3d (23.19 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/potato.i3d (4.89 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/potatoHaulm.i3d (1.15 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/sugarbeet.i3d (3.15 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/sugarbeetHaulm.i3d (0.76 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/sunflower.i3d (8.48 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/soybean.i3d (4.25 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/oilseedRadish.i3d (1.17 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/foliage/bush01.i3d (17.56 ms)
Info: transform group 'bush01' has elements very far out from the cell edge (29.61% expansion)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/foliage/bush01Winter.i3d (11.54 ms)
Info: transform group 'bush01Winter' has elements very far out from the cell edge (29.61% expansion)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/oat.i3d (5.06 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/cotton.i3d (4.91 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/millet.i3d (9.71 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/cabbage.i3d (6.01 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/cabbageHaulm.i3d (1.91 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/redCabbage.i3d (6.03 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/redCabbageHaulm.i3d (1.38 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/lettuce.i3d (6.12 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/lettuceHaulm.i3d (1.42 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/rye.i3d (8.04 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/spelt.i3d (8.69 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/carrot.i3d (3.80 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/carrotHaulm.i3d (1.41 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/onion.i3d (3.85 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/onionHaulm.i3d (0.85 ms)
C:/Users/Doug/Documents/My Games/FarmingSimulator2019/mods/FS19_DELTA/maps/newFruits/foliage/hops.i3d (9.30 ms)
D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/weed.i3d (6.50 ms)

Bilbo Beutlin (BBeutlin) 03.06.2020 17:12
Very often a Windows update causes strange behaviour upto crashes. Maybe by new drivers or due to changes/reset of attitudes.

1. Check your most important system and gfx settings for unwanted changes.
2. Look for OneDrive settings. FS related files don't like cloud storage at all.
3. Delete in folder "{USER}\AppData\Local\GIANTS Editor 64bit ..\" the file "editor.xml" and all files in folder "shader_cache".

Doug Williams (Dougw133) 03.06.2020 18:27
The editor opens with other maps and files. Just not this one. I also already tried deleting the xml and shader cache files yesterday.

I'm afraid it may just be corrupt. I am certain the last thing I did was open the map and delete two transform groups that contained a few places objects. I then saved the map and it never opened successfully again.

right before I deleted those two transform groups I made a backup of my I3D and all associated files under it. That backup also will now not open. It's very confusing since I did not alter any other files, xml's or delete anything

Doug Williams (Dougw133) 03.06.2020 18:28
What's also disappointing is that there are no errors in either log

This is the last thing in the editor log, and also when I load in game.

D:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/weed.i3d (6.50 ms) Is it related to foliage?
Can user attributes cause it not to open the editor?

Doug Williams (Dougw133) 03.06.2020 19:27
Just recovered it after hours...

I deleted every particle system emitter in the map as there were only 20 or so. I also deleted any user attributes associated and the map loaded. I had added seasons Admirer to a waterfall emitter and the map was working ok with it, so not sure what eventually happened there. Either way, its back. Who knew an emitter could cause that.

I should add that they were water vapor, and waterfall emitters. There are smoke emitters in the map as well. So it was water related ones that were the issue. I may go back and start removing them one by one to find out exactly which one and why so I can at least leave the info here.

Note: Log in to post. Create a new account here.