Community Forum

Editor Crahing when loading .i3d

Forum Overview >> Editor

Created31.03.2021 06:15

Anthony Napierala (duramaxman0102) 31.03.2021 06:15
okay- so... here it goes... I was creating a map (all was fine) well, i added in vehicles (static vehicle) from the games "data" file. to be more exact- vehicle 5, vehicle 1 and vehicle 3. They were fine. i then added in the truck2014 from the "data" file. i removed its lights, and anything Player related (this done after importing it into my map. NOT the games i3d file.) all was fine. i used the script to remove dirt and it crashed my maps i3d. i then reloaded my map and redid what i had done above. HOWEVER, this time i saved the i3d before applying the "remove dirt" script. same issue occurred. GIANTS editor crashed once more. i then tried to reopen my maps i3d and it would crash upon opening. does this every single time... anyway i can remove these vehicles i put into the map?! since im almost certain that's the problem since it worked fine prior to being saved... Below is the editor log from the editor when trying to load my i3d. *note- graphics drivers are up to date. i had NO issues with loading prior to what i did mentioned above*

GIANTS Engine Runtime 8.0.0 (23100) 64bit (Build Date: Nov 16 2020)
Copyright (c) 2008-2019, GIANTS Software GmbH (, All Rights Reserved.
Copyright (c) 2003-2019, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 8.2.2
Main System
CPU: AMD Ryzen 7 2700X Eight-Core Processor
Memory: 16315 MB
OS: Windows NT 10.0 64-bit
Physics System
Version: 5.9.5
Thread(s): 2
Audio System
Driver: SoftMixer WASAPI Stereo
Version: 2018.11
Frequency: 48000
Max. active sources: 256
Render System
Driver: OpenGL
Card Vendor: NVIDIA Corporation
Renderer: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2
Version: 4.5.0 NVIDIA 465.89
Shader Version: 4.50 NVIDIA
Max. Texture Layers: 16
GL_AMD_depth_clamp_separate not supported
Started 3 threads for threadpool 'Render threadpool'
Hardware Profile
Level: Very High (auto)
View Distance Factor: 1.300000
Shadow Quality: 2.000000 Base-Size: 2048 Filter-Size: 16 Shadow Focus Box true
Shader Quality: 3
Skip Mipmaps: 0
LOD Distance Factor: 1.300000
Terrain LOD Distance Factor: 2.000000
Terrain Normal Mapping: Yes
Foliage View Distance Factor: 1.600000
Volume Mesh Tessellation Factor: 0.750000
Tyre Tracks Segments Factor: 4.000000
Max. Number of Shadow Lights: 5
Max. Number of Lights: 512
Max. Number of Lights Per Cluster: 32
Bloom Quality: 5
SSAO Quality: 15
DOF: Enabled
Cloud Quality: 4
EnvMap Blending: Enabled
Check for updates (
C:\Users\duram\Documents\My Games\FarmingSimulator2019\mods\FS19_RedMountianAcres\maps\map01.i3d (3042.04 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/wheat.i3d (11.47 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/grassDense.i3d (6.67 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/canola.i3d (7.92 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/barley.i3d (5.97 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/maize.i3d (11.96 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/decoFoliage.i3d (40.21 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/potato.i3d (8.98 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/potatoHaulm.i3d (2.11 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/sugarbeet.i3d (6.61 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/sugarbeetHaulm.i3d (1.49 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/sunflower.i3d (11.87 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/soybean.i3d (7.79 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/oilseedRadish.i3d (2.52 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/poplar.i3d (11.33 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/foliage/bush01.i3d (19.07 ms)
Info: transform group 'bush01' has elements very far out from the cell edge (29.61% expansion)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/foliage/bush01Winter.i3d (12.66 ms)
Info: transform group 'bush01Winter' has elements very far out from the cell edge (29.61% expansion)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/oat.i3d (8.61 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/sugarCane.i3d (10.49 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/sugarCaneHaulm.i3d (1.49 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/cotton.i3d (8.87 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/foliage/alfalfa.i3d (8.37 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/foliage/clover.i3d (6.14 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/foliage/rye.i3d (9.11 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/foliage/millet.i3d (9.13 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/foliage/triticale.i3d (10.00 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits2/foliage/carrot.i3d (5.14 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits2/foliage/carrotHaulm.i3d (1.92 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits2/foliage/onion.i3d (5.12 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits2/foliage/onionHaulm.i3d (1.10 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits2/foliage/hops.i3d (10.74 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits2/foliage/tobacco.i3d (10.74 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits/foliage/cabbage.i3d (10.53 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits/foliage/cabbageHaulm.i3d (2.60 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits/foliage/redCabbage.i3d (8.23 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits/foliage/redCabbageHaulm.i3d (1.81 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits/foliage/lettuce.i3d (8.19 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits/foliage/lettuceHaulm.i3d (1.84 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits/foliage/poppy.i3d (9.52 ms)
C:/Users/duram/Documents/My Games/FarmingSimulator2019/mods/FS19_RedMountianAcres/maps/newFruits/foliage/spelt.i3d (11.64 ms)
C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 19/data/foliage/weed.i3d (13.30 ms)

Unknown 31.03.2021 19:00
I'm having kind of the same problem. I wanted to remove something from an map, but the map does not open at all. I didn't even edit anything on the map yet and I'm just trying to open it. It just closes, there is no crash message

For more details it's the Farming Simulator 2011 map1 I'm trying to open. I want to remove the darn scarecrow without having any extra stuff added by mods. I just want the scarecrow gone

No mods are currently installed. Only the bottle finder was installed, as I was getting tired of finding all 100 bottles for the 3rd time on my own again because the save file suddenly deletes itself

Anthony Napierala (duramaxman0102) 01.04.2021 08:58
I've actually fixed my problem. took some time to figure out. But i got it! in your case, this may help as well... Open your i3d file of your map in notepad++ find the line of which you do not want. delete it- save the file and your map "should" open. in my case i knew exactly what i was looking for (the "truck2014" i put into my map) searched for that and removed every line that was associated with it. Saved the file. My map then opened without any issues. Note- make sure when removing the lines, you follow the sequence the scrips/ lines of code are in. otherwise your map will come up with and error "filed to open i3d"

Also- make sure your map folder (if its a mod) is in an unzipped format. Otherwise it will not open in the editor

Note: Log in to post. Create a new account here.