Community Forum

Problem with movingParts by conferting mod from fs19 to fs22

Forum Overview >> Editor

Created25.11.2021 20:30

Thomas Mehner (sucoon) 25.11.2021 20:30

i have a problem with movingparts. i converted a mod from fs19 to fs22. it seems like, that movingparts works in an other way. for example my steering left and right side are not conected anymore and my axis is moving with the wheel.

lunchbox85 also noticed the problem, he think something with z-axis.

soemone has an idea what changed or what i have to do to fix it?

Afmodding (1DAFUL) 02.01.2022 18:21
Hello Thomas

I have got the same problem.
It is not an issue and the solution is simple.

One of my mod is AFM_Santana_88. I converted from FS19 to FS22 and realised that suspensions doesn't work correctly, doesn't follow reference objects.
After 4 days and tons of thousands of testing and 100 stroke, finally..... :D

for instance:
<movingPart node="suspension1_node" referencePoint="suspension_LeftFront_Ref" referenceFrame="suspension_LeftFront_Ref" isActiveDirty="true" maxUpdateDistance="30">
<translatingPart node="suspension2_node"/>

In this case all the axis has been pointed same Z direction but, "suspension_LeftFront_Ref" was in -90. I changed this number from -90 to 270. In visual nothing changed, the axis pointing the same direction.
Well, FS22 doesn't like negative numbers in reference objects.

I hope it was helpfully information.

Nord Hawk (NordHawkSteam) 20.07.2022 21:25
This is not a reply to Thomas Mehner (sucoon) but a big Thank you to Afmodding (1DAFUL).

Just like you, I have spent countless of hours trying to figure out what causes this problem. I have solved this issue before but after reading your reply to Thomas Mehner (sucoon), I realize I have been lucky when solving these issues in the past by simply copying and replacing working similar parts from another vehicle and used those references etc.
Today I tried your solution on a hydraulic lift-arm, but I 0;ed out all the values except the "Translate Z" which needed to be where it was at 0.451 and "Rotate X" which I left at 90 instead of -90 pointing down instead of up, and like magic it started working for me without all the fuzz of importing and replacing parts from other vehicles.

This was extremely helpful information, made all the difference! I cant believe it was that stupid simple :)

and Thomas, I hoped it helped you as well.


Note: Log in to post. Create a new account here.