Community Forum

Giants Editor Crash

Forum Overview >> Editor

Created06.12.2021 03:02

Aaron Abel (abel663) 06.12.2021 03:03
I can use editor 9.0.1, after i get file loaded i cannot expand the Scenegraph. Also cannot close the program, i have to force shut it down.

Bilbo Beutlin (BBeutlin) 06.12.2021 04:47
Look into GE log for errors: %LOCALAPPDATA%\GIANTS Editor ...\editor_log.txt

I'd guess incompatible mod/map or lack of resources (RAM/VRAM).

Aaron Abel (abel663) 06.12.2021 18:50
There are no errors in the log file. i have been modding for years with this computer on all the other games and have had no issues.

Markus Othmer (Muckefuck) 06.12.2021 19:03
Checked the Installationpath ->Preferences in the Editor? Shoud point to your FS22 Installation.

Aaron Abel (abel663) 06.12.2021 19:09
this is the path "C:/Program Files (x86)/Farming Simulator 2022/"

Bilbo Beutlin (BBeutlin) 06.12.2021 21:45
Can you open game default i3d's without problems?
If so, your mod i3d is incompatible or corrupted.

Aaron Abel (abel663) 07.12.2021 02:43
it does not work with the default game I3d's.

Matt Dahms (MDahms) 07.12.2021 22:22
the editor v9.1 comes up fine but as soon as I open a *.i3d file it will crash and shut down
do you have a Solution?

Matt Dahms (MDahms) 07.12.2021 22:30
the editor v9.1 comes up fine but as soon as I open a *.i3d file it will crash and shut down
do you have a Solution?

Matt Dahms (MDahms) 07.12.2021 22:30
the editor v9.1 comes up fine but as soon as I open a *.i3d file it will crash and shut down
do you have a Solution?

Bilbo Beutlin (BBeutlin) 08.12.2021 03:54
Scroll back some posts or search by Google.
I'm too tired to answer the always same upcoming questions.

Aaron Abel (abel663) 08.12.2021 04:00
No solution has arisen for me yet. I've tried to reinstall it with other download files. It seems to be a hickup with the program. Some people can install it without any issues and some are having my problem. I have no errors when I run the program it just freezes up.

Matt Dahms (MDahms) 08.12.2021 14:24
I apologize for asking the same question but I'm not finding a solution in the past posts

I too have these things you have with no success.
I have used Giant Editor on FS-15,17, and 19 with no issues after loading *.i3d file.
also have tried different computer and having the same result with GE 9.01 for FS22

Matt Dahms (MDahms) 09.12.2021 16:51
I fix it using WinDirStat found many files referencing to FS19, updated them and or deleted the text,

Aaron Abel (abel663) 09.12.2021 18:20
Could you be more specific of how you did that?

Matt Dahms (MDahms) 09.12.2021 21:44
I will Try,
so a little back story, I'm a Senior Citizen that loves FS and editing mods with GE.

I start App called WinDirStat, then C:/ _then Owner_ Then Local_then look for any older GE Files And removed them.
then looked for GE_9.0.01 Folder open it then open_ Editor_Log.txt using NotePad++ looked for anything line that was looking in the wrong Drive changed it. also, if the line had thing verbiage with old GE software I removed it or Change it
hopfully that makes sense

thank you asking

Aaron Abel (abel663) 09.12.2021 23:12
You mean C:/Users/abel/Local?? If so i dont have any Local File.

Matt Dahms (MDahms) 10.12.2021 01:06
C:/uers/Owner/AppData/Local/Giants Editor 64Bit 9/Files/editor_log.txt

Aaron Abel (abel663) 10.12.2021 21:19
When I start i3d it askes me to select which giants editor to use. I have two file paths

C:/Program Files/GIANTS Software/GIANTS_Editor_9.0.1_64-bit/editor.exe and

C:/Program Files/GIANTS Software/GIANTS_Editor_9.0.1_64-bit//editor.exe But the second one doesnt exist when I trace the path out...

Gary Holden (garyholden) 10.12.2021 22:16
This is a problem Giants should create a fix for as so many people are having this problem.

Matt Dahms (MDahms) 10.12.2021 23:50
when i use WinDirStat I could see File Path, so Just removed all but the one that was right for me

Aaron Abel (abel663) 11.12.2021 17:37
that second path does not exist, but i can start giants with it.

Louca Mandela (Louca) 12.12.2021 14:14
I have a problem I want to launch Giants editor but two segments after launching giants editor it closes and its done with all the versions

Aaron Abel (abel663) 15.12.2021 15:38
My computer finally did a windows update and now Giants Editor works fine with no issues.

Note: Log in to post. Create a new account here.