Community Forum

Terrain mesh paint mode - extend for x4 map

Forum Overview >> Editor

Created06.12.2021 11:04

Tim Sprinkhuizen (timspr) 06.12.2021 11:04
Dear all,

Using the tool "terrain Mesh Paint mode" a lot to place trees on the map. However on the x4 map this only applies on the normal map land size.
The land outside the standard map land square doesnt apply trees with this tool. It does not provide an error but it also doesn't place trees.

Anyone know how to extend the land it applies the trees to in this mesh paint mode tool for a x4 map?

Nikita Vlasov (nikita) 07.12.2021 05:13

tell me how you made it work? he doesn't want to draw a grid at all

Tim Sprinkhuizen (timspr) 07.12.2021 16:02
Dear Nikita,

First you have to select a tree model. Then you select the terrain mesh paint mode in the top and when you click with the mouse button (in the Brush section for example when you have chosen "RMD" right mouse button as "ADD") it should add the random trees to your map.

Only in the x4 map it doesn't add then the trees on the extended map size space, only on the default x2 map size space.
Still havent found out a solution, anyone an idea?

Chris Stokes (IChristoI) 07.12.2021 23:59
I think this is because the .grle files for the 4x map are not the correct resolution - there are quite a few dodgy converted '4x FS22 maps' out there that aren't actually 4x when you look behind the scenes so to speak

Tim Sprinkhuizen (timspr) 08.12.2021 11:19
Hi Chris,

Thanks for your steer and as your right as on another download it does work at x4 so the files weren't scaled correctly.

The strange thing is that when I import objects on the map it will not work anymore.


Ed Propsner (crotchfrog) 18.12.2021 14:58
There's no doubt that something didn't scale correctly but does anyone know exactly which file didn't scale? I looked into the obvious culprits like density maps and infoLayers but have been unable to find it. It's also completely possible that I did find it but am not scaling something properly myself.

William Rowe (Bonger76) 18.12.2021 17:08
4x map,
_weight.png- resolution 4096x4096
infoLayer_farmland.grle 2048x2048
infoLayer_navigationCollision.grle 4096x4096
infoLayer_placementCollisionGenerated.grle 2048x2048
---the other.grle are this
infoLayer_.grle 8192x8192
---your .gdm need to be 8192x8192
map_dem.png 2049x2049

open the map up in notepad++ and make shure that in the "<TerrainTransformGroup" ,line in the,"unitsPerPixel="2",is still 2,I have seen map modders change this to increase the map size doing that way causes scaling problems.

Ed Propsner (crotchfrog) 18.12.2021 23:43
Thanks William, that's good info to have! As it turns out not all of my files were the proper sizes. I fixed all of the ones that needed it but my mesh paint still does not work outside of the 2x area. I wonder what I'm overlooking this time?

Grim Reaper (GrimReaperAlphaX) 19.12.2021 16:10
There a few blank versions of 4x size map,all have the same issues.
I know how to upscale map properly so i started from the scratch and still the same issue,thing is most possible cause for this is a hard coded size of the map which can be only 2x,this is coded in the editor itself so if giants doesnt change this in near future we are stuck with default map size.

PS: new version of the editor would soon be released because newest update in the game caused problems with shaders,so we are all left to see what exatcly changes would be made.

Ed Propsner (crotchfrog) 19.12.2021 17:02
In one of the above comments Tim said he found a 4x copy that worked. I also scaled mine myself. If William's resolution's are correct I scaled two of them to the wrong size, even though it still worked fine I was hoping that would be the issue. It wasn't. Don't hold me to this but I could swear I had at least two instances where it worked outside of the 2x area. I'm not 100% on that and it could have been a fluke? Odd that they would hard code the size restriction since they know how heavily these maps are modded and they count on us to do exactly that. To me it would make the most sense to tie it into the placement collision map. That doesn't seem to be the case since I'm pretty darn sure mine is correct and it still does not work. I've looked through everything I could think of and haven't found anything yet. I'm convinced it's an easy fix and that I'm overlooking the solution. Of course I could be dead wrong and this is why I'm not a betting man :)

Grim Reaper (GrimReaperAlphaX) 20.12.2021 11:50
@Ed Propsner im modding the game for years and years,started back then with FS13,i made many maps in FS15,FS17 And F19 so im sure i know what im doing,so problem currently is not in scaling.
Even with all layers correctly scaled and set,issue with painting outside of default size map area still present,map loads fine but you cant paint,it's just a clear terrain sadly.
That's why i would say that issue is connected with the editor,of course i could be wrong.

Ed Propsner (crotchfrog) 21.12.2021 03:11
@Grim Reaper: Tough to say and it's a real shame too. It's a super-handy feature and about time they implement something like this. It's a step in the right direction for the editor but not as useful locked in at 2x.

Ed Propsner (crotchfrog) 21.12.2021 03:30
@Grim Reaper: Out of curiosity I download a 16x blank card and the mesh paint feature works perfectly all the way out to the very edge of the map in all directions.

William Rowe (Bonger76) 21.12.2021 04:17
I'm not having any problems painting from the middle all the way to the edge of my 16x map .My map_dem.png is 4097x4097,and A bit depth of 16.
this is from my .i3d, you need to make shure to make this what ever size of weights you are useing---lodTextureSize="8192"---

<TerrainTransformGroup name="terrain" static="true" collisionMask="524255" nodeId="5326" heightMapId="1" patchSize="65" maxLODDistance="750" heightScale="255" unitsPerPixel="2" lodBlendStart="200" lodBlendEnd="300" lodTextureSize="8192" lodBlendStartDynamic="50" lodBlendEndDynamic="65" detailLodBlendDelta="5" materialId="676" castShadowMap="true" occLevel="1" occFaceCount="100" occMaxHausdorffDistance="10" occMaxHausdorffDistanceExtra="10" occMinHorizontalDistance="1" occDistanceWeight="1">

your _weight.png bit depth could be wrong,it should have bit depth of 8.

This is what I suggest you do make a file on your desktop whatever you whant your map to be,go open up the base mapUS in the editor ,
go to, export all with files,when it open's ,open the file on your desktop,save as myMap_name,say yes to both close then go to your descktop and open the myMap_name .i3d, delete elmcreek ,keep the gameplay ,Save get a 4x dem 2049x2049 out of a 4x map you know works put it in the data folder give it the same name as the base map_dem change the name of base dem or remove,then open the .i3d up in notepad++ and find the file path for the map_dem
<File fileId="1" filename="$data/maps/mapUS/data/map_dem.png"/> change to <File fileId="1" filename="data/map_dem.png"/> save. If you whant to change your wieghts size 4096x4096 you will have to change path to them in your map,I know this works did it as I was wrighting this.
you still have to do alot of work to get it to open in game with all the .xml's. This is how I started my 16x conversion.This way it make shure that
your new map.i3d is set up right no problem from conversion.

Ed Propsner (crotchfrog) 21.12.2021 11:58
This is something I usually do but not in this instance. I'm working on something a bit different this time and took an existing 2x map and scaled it to 4x with everything still in place, so it sort of makes sense that the mesh paint only works up to 2x. The only real difference I can see is that I usually keep my _weights at 4096 and this time around they are all 2048. I tried to scale them, but all of my attempts turned the entire map to animal mud. This map is almost done so I'll have to finish it with mesh paint the way that it is. The only reason that I keep trying to fix it is because my OCD won't let me NOT fix it, LOL. I'm not usually content knowing that something works or does not work, I want to know why and understand how it works. I could be using it right now if I knew exactly what is keeping it from working in the first place.

BTW, you say if you want to change your _weights to 4096 you will have to change the path to them. What path? The _weights are always stored locally in the data folder. data/some_weight.png. Are you saying something different needs to be done?

William Rowe (Bonger76) 21.12.2021 17:34
The path in your map .i3d.Open your map .i3d and look to see where it is reading them from,when you do it the way I stated it puts the data file in whith the map .i3d but the map is still reading it like this, $data/maps/mapUS/data/dirt01_weight.png"/> it is note loading them from your new map.
you have to remove the " $data/maps/mapUS/ " so that it will read the data file in your map.

As fare as try to make your 2x map and making it 4x, I would use GIMP photo editor, get a good clean 4x map_dem.png open it in gimp then take the 2x map_dem.png open as a layer and it should put it right in the center of the map then export as to wherever you whant it you need to have it exported as 16bpc GRAY their is a dropdown tab the export,then put in the map open in editor and the 2x terrain is righ.From the edges of the 2x to the edges of the 4x is all you to work,As fare as your wieghts go you should be abale to do the samething ,they need to be exported as 8bpc GRAY
Alot of work ,and they have to have the same order and name so the editor can read them right ,like if you are taking a grass wieght from another map and putting into another map the order might be off so it might show as rock.

old map might be like this in the editor--------new map in editor

mud - mud
dirt - dirt
grass - rock
dryGrass - grass
rock - dryGrasss
my map wieghts are all blank so when I open the map in the editor it is painted all mud that is base nothing painted on the wieghts.png
it is a color number order.Like they have the new paint by spline script I could not get it to work so I opened up the script editor GE and it a defolt number of 80 thier is no 80 or texture I put 70 in an exicuted and it work so had to go through and figure out my paint type numbers for them.
You wieghts should be 4096 it will give you better painting not so blocky and you need to change the" lodTextureSize="2048" to 4096"

<TerrainTransformGroup name="terrain" static="true" collisionMask="524255" nodeId="5258" heightMapId="1" patchSize="65" maxLODDistance="750" heightScale="255" unitsPerPixel="2" lodBlendStart="200" lodBlendEnd="300" lodTextureSize="2048" lodBlendStartDynamic="50" lodBlendEndDynamic="65" detailLodBlendDelta="5" materialId="654" castShadowMap="true" occLevel="1" occFaceCount="100" occMaxHausdorffDistance="10" occMaxHausdorffDistanceExtra="10" occMinHorizontalDistance="1" occDistanceWeight="1">

When you scale up and save you wieght the photo editor might not be pick up on the gray scale when you save, like I don't think you can use it won't save it right.

Chris Stokes (IChristoI) 21.12.2021 21:10
I can no longer paint anywhere on my 4x map using the Terrain mesh paint mode and I really have no idea what I have changed/broken.
My 4x base map (which I created myself) still works fine, but not the later version of it where I've started to build the map.

I replaced the .grle and .gdm files from the base map into the mod map, thinking that I may have accidentally resized one of the files, but this does not solve the issue, despite the base map behaving as expected.

Ed Propsner (crotchfrog) 21.12.2021 22:24
Can you still paint within the 2x area or it does not work at all now? What were you doing when it stopped? I'm curious because I'm trying to determine exactly what is regulating the mesh paint mode.

Chris Stokes (IChristoI) 21.12.2021 23:22
Nope, it won't let me paint anywhere on the map.
Unfortunately, I've made quite a few changes without realising that this was even an issue. Yep, I'd really like to know which file(s) are responsible for controlling the mesh paint mode. We need documentation!!

Ed Propsner (crotchfrog) 22.12.2021 00:21
I do that myself, change so many things there is just no way to tell what triggered the issue. But hey, when you're on a roll, you're on a roll! I hear ya', thorough documentation is a recurring dream of mine, lol.

I don't think the terrain paint has anything to do with it ... did you add any placeables to the map?

Ed Propsner (crotchfrog) 22.12.2021 16:40
@William: I definitely agree that my weight files should be a higher resolution so painted textures are not so clunky and blocky. Have you come across the issue yet where GE reverts your weight files from 4096 back to 2048? The last attempt I made at converting them GE kept putting the files and lodTextureSize in the I3d back to 2048.

Jānis Strautiņš (strauts6) 22.12.2021 21:15
" I tried to scale them, but all of my attempts turned the entire map to animal mud. " This is caused by wrong resampling while resizing, cant remember which method is the right one.

Ed Propsner (crotchfrog) 22.12.2021 22:01
Perhaps not the "entire" map, but definitely the areas with the textures I'm trying to enlarge. So, it puts them in the right place, they are just mud now. I tried all the resamplings that had to do with enlargement, but all had the same result. Maybe it's one of the others? This would not be a problem if I could swap them out a texture at a time but when I do GE just resets everything to 2048 on its own. Most likely I have to swap every texture at the same time ?

William Rowe (Bonger76) 23.12.2021 01:51
@Ed Propsner the only way I can think tha the editor would change lodTextureSize from 4096 to 2048 is that your map is reading wieghts files that are 2048x2048,need to check in the.i3d the wieghts path and that they are reading your 4096x4096 wieghts .png.when you open map and save and it is reading 2048x2048 it could be changing the lodTextureSize .

Switcher Switch (Switcher) 31.12.2021 12:03
Hello, i have problem with my 4x map, map dem 2049*2049, density map fruit , ground 8192*8192, infoLayer_placementCollisionGenerated 2048*2048, infoLayer_indoorMask 8192*8192, infoLayer_navigationCollision 2048*2048, infoLayer_placementCollisionGenerated 2048*2048 , BUT when i created new game , my infoLayer limeLevel and plowLevel has size 4096*4096, but its wrong, this level should have size 8192*8192, does anybody help with this problem ? Thank you

Alexander S (Foxxi) 02.01.2022 19:29
Having the same issues.
As soon as all files have the correct resolution I am no longer able to use the Terrain Mesh Paint function.

Funfact: I can paint outside of the terrain when I'm painting on the edge of fhe map...

Dakluit Bla (dakluit) 06.01.2022 22:47
Anyone found a sollution for not being able to paint with the mesh tool? Im also running into the problem where you can't paint outside the standard size map

Ed Propsner (crotchfrog) 07.01.2022 04:13
No, I was hoping for a solution by now myself. I spent a good bit of time trying to track down exactly what is responsible for governing the mesh paint tool but I came up dry. I found a 16x card that works all the way out to the edge of the map but was told that it fails as soon as you start working with the map, making changes, and adding items. I'm sure that it's one of the infoLayers or density maps but I don't know which. My next project was to start changing the resolution of each one, one at a time, back to the standard resolution and see if it makes a difference but I haven't made it that far yet. I'm almost done with my current map so I figured I would keep an eye on it when I start resizing my next map.

Josh Nurrenbern (jwnurrenbern) 07.01.2022 21:32
I have been having this problem also. We figured out that if you have any sort of plane on the map then the tool doesn't work at all or will only work in the center portion. So if you want to use the mesh tool, what I have found is export all your planes, use the mesh tool, then reimport the planes once your done.

Ed Propsner (crotchfrog) 07.01.2022 23:24
@Josh: Nice find! What in PIA though, now just need to figure out how to make it work w/ active planes.

Hello I'm (PicSoul) 08.01.2022 02:23
Placing all planes in a transform group and then raising them above the map/ground seems to let you paint. So, create a transform group and place all planes within it. Move the group to Y 400 or so and paint, return when done painting.

Ed Propsner (crotchfrog) 08.01.2022 02:34
Yup, worked it out. It sees the plane as a collision, I guess. Seems so simple now, but yet the simplest solutions always seem to escape me. Overthinking it, I guess. I'm getting slow in my old age. :)

Props to Josh: He deserves a cookie or medal for finally figuring it out.

William S. Martin Jr. (nitrodad1115) 10.01.2022 20:49
If I may ask. I noticed the terrain mesh paint tool works perfect on all 3 base maps without exporting or moving the planes . But it fails to function on every mod map i have tried including a blank standard and 4x map. Would anyone have an answer as to why? its seems as though every map conversion i have seen is missing something in the conversion process.

Ed Propsner (crotchfrog) 10.01.2022 21:25
Like you said, there is always something missing or wrong with blank cards downloaded from the net. In those maps it's hard to say without looking at it. My guess would be the water plane or the map border. For whatever reason it's seeing them as a collision? This is purely a guess as I wouldn't really know without tinkering but those would be the only 2 planes typically left on a blank card. It could also be that the collision maps weren't converted correctly, that's very likely. I found a 16x blank that it worked on with no problems so your guess is as good as mine right now.

William S. Martin Jr. (nitrodad1115) 10.01.2022 23:01
@ED. after some testing i figured it out.. I was having no trouble placing trees on a base map until i exported it and flattened the terrain . then tool would stop working . tried taking out water planes everything.. The solutions was to change the slope start limit in the terrain paint toool menu to 0 . it was defaulted to 3.92 i think .. as soon as i changed it to 0 it let me place trees even with water planes present. it must see the water planes as a flat plane and prevent placement unless you reset limits.

Ed Propsner (crotchfrog) 11.01.2022 00:11
That's definitely something to keep an eye on, texture paint is the same way. It's a super handy feature but if you're not used to it, it can throw you for a loop if it gets accidentally changed. Both tools should always be set to 0-90 for normal use. Only change those parameters if you want to only paint slopes 45 - 60 degrees for example.

Christopher Kimball (FunnyFarmGaming) 12.01.2022 19:28
I am fighting this same issue. Did anyone solve it? I cant paint with the mesh tool at all and this is a standard map from the game that I cleared and started working on. I am not sure if this is an info layer issue or something else

Ed Propsner (crotchfrog) 13.01.2022 01:46
The closest we have come so far is Josh figured out that if you have any type of plane in close proximity to where you're painting, it will not work. If you have a photo plane for reference, water plane just below the surface, or even the bg border ... they all seem to possibly be able to effect it. I've been through the collision maps, infolayers, etc. and couldn't find a work-a-round. I had a photo plane that I kept just below the surface when I wasn't using it and as soon as I removed it, the mesh paint worked on the entire map.

Wolfgang Löper (enigma) 31.01.2022 00:28
I couldn't do "terrain mesh painting" on my 4x map either. After I inserted some "texture layers" with the "layer manager" in GE 9.02, I executed the "create ground collision map" script in GE. After restarting the map, I was miraculously able to run the "terrain mesh painting" on the entire area of ​​the map.
In short:
- Start map in GE.
- Execute script "create ground collision map".
- Save map in GE and exit.
Restart the map in GE.
I hope I could help with this hint.

Jürgen Pauly (xmcmarax) 01.03.2022 17:54
Bevor man Terrain mesh paint mode benutzt einmal die Waterplanes komplett auf 10000 setzen und dann Terrain mesh paint mode ausprobieren. Das hat bei mir funktioniert. Hatte bei mir geholfen

Chris Stokes (IChristoI) 26.05.2023 23:45
I should have posted back in here as soon as I found this, but better late than never!

The reason I was previously having issues (as below):
"I can no longer paint anywhere on my 4x map using the Terrain mesh paint mode and I really have no idea what I have changed/broken.
My 4x base map (which I created myself) still works fine, but not the later version of it where I've started to build the map."

Was because there was a map overlay that I was using as a guide for roads, fields etc hovering above my terrain. This was causing the paint mode to not properly target the terrain, and so nothing was being painted down. The only way I found to fix this was either to remove the overlay entirely or simply move it far above from the terrain using the y axis.

Note: Log in to post. Create a new account here.