Community Forum

Placeable Behavior

Forum Overview >> Editor

Created04.01.2022 16:14

Ed Propsner (crotchfrog) 04.01.2022 16:14
I'm having issues with some of my placeables (GE 9.02). Some of my placeable objects are not spawning where they are supposed to be. Usually when this happens, I accidentally grabbed the coords of a child object or the object was exported that way from blender, etc. Mostly this seems to be only happening with placeables that do not come from the game itself, except for one game placeable that spawns about 10 meters away. All other game placeables and a few personal ones or just fine.

- The gizmo is centered on the object
- I tried zeroing everything out to world origin and freeze transformations
- I tried exporting to Blender and resetting origin
- Triple checked the XML and they all meet FS22 format

A few of these placeables are different game objects that I put together under one TG. I originally thought that may have something to do with it until one of the included game placeables didn't spawn right. Am I missing something here or is there a way the coord system could be out of whack?

** Edited for typos

Gregg Macfarlane (SirCuddlesWorth) 04.01.2022 18:44
Maybe it has it's own X,Y,Z already on it overriding your X,Y,Z? Have you imported to the editor and then set the X,Y,Z to 0,0,0.

I have found If it's a custom Object, I have to Import it into the scene, then place it where I want it. Then copy the X,Y,Z Rotation to the placebles.xml. After change the objects X,Y,Z in the game editor to 0,0,0, and export-save the updated version of it. Then delete it from the scene. Otherwise, any default X,Y,Z on the Object's i3d will fight the placement I found.

Sorry I can't be of more help, only thing I can think of right now. But I'm new to it lol.

Ed Propsner (crotchfrog) 04.01.2022 21:14
Yup, I tried that. What is really strange is that I can take any random object from the SG, it doesn't matter which, and place it in the same spot and it always gives me the same exact coords like it should. When I press "F" to frame the object, the object stays where it is, and the camera moves halfway across the map up in the air somewhere. It almost seems like a problem with the coords more than a problem with the object since it doesn't matter what I put there. I've tried everything I could think of and nothing is making a difference.

I do find though, that 99% of the time it's not a problem with anything except me. I'm usually overlooking the solution. This one has me stumped.

Note: Log in to post. Create a new account here.