Community Forum

Maya 2011 normalmap export problem

Forum Overview >> Maya Exporter

CategoryMaya Exporter
Created20.06.2011 22:59


Martin B. (unknown) 20.06.2011 23:07
Hi,

i got my model setup in maya with a phong shader assigned an after i converted it to i3d format the normalmap causes a massive problem. The texture seems to "move" if i change the camera position.
The phong shader has diffuse-, normal- and specularmap assigned and in maya high quality view everthing seems ok.
If i delete the normalmap in my i3d file the problem seems to be fixed. I talked about this problem with many people, but nobody could solve it. I've tried many opportunities but nothing worked.
I got this problem with all my models that i have converted. Diffuse- and specularmap are looking fine, except of the normal map.
I hope you can follow my description. Manuel aka "face" said this problem appears very often but he does not know the solution for it.

Regards

Martin

Stefan Geiger - GIANTS Software 24.06.2011 08:36
If the normal map has an alpha channel, parallax mapping (also called virtual displacement mapping) is activated. This is an technique which distorts the texture coordinates based on a height map that is stored in the alpha channel of the normal map.
With this you can achieve results that look extremely bumpy, for example the wall to the street just at the farm in Farming Simulator 2011 uses parallax mapping.
Or you could check out the wikipedia article about it:
http://en.wikipedia.org/wiki/Parallax_mapping

So the problem of your normal map, is that it has some random values (or high values) in the alpha channel. What you need to do is to store the normal map without an alpha channel. You can do this by flattening the file first. In Photoshop you can do this my selecting in the menu Layer->Flatten Image.
You still have several layers, but you need to have the "Background" layer.

In the GIANTS Editor you can see if an object has a parallax map enable by selecting "Parallax Mapping" in the menu View->Debug. Each object that has a parallax map is shown in pink.


Note: Log in to post. Create a new account here.