Community Forum

Maya 2011 Export i3d. Textures not scaled

Forum Overview >> Maya Exporter

CategoryMaya Exporter
Created22.11.2011 16:37


Lenio Crameri (Lecra) 22.11.2011 16:44
Hi all,

I have encountered an issue when I'm exporting my model to i3d. After have modeled and textured my model with textures (2048x2048 in JPG, PNG or DDS1/DDS3) I always have a problem that in GE the model looks like as I had not appliad any UV mapping and scaled the textures.

In Maya it looks like this image: http://www.abload.de/image.php?img=maya_orginalb37gd.png
In GE it looks like this Image: http://www.abload.de/image.php?img=ge_import577w6.png

If you want you can watch the video how I did the whole procedure: http://www.youtube.com/watch?v=CuGjqAggSm0

I'm using Windows 7 Pro x64, Maya 2011 SP1x32 using i3d exporter v4.1.7 or v4.1.9. Issue happened with both version of exporter driver.

Anyone that can point me to the right direction?

Many thanks for your help in advance.

KR,Lecra

Stefan Geiger - GIANTS Software 23.11.2011 09:44
The parameters of the place2dTexture node are not used by the exporter. You should modify the UV coordinates directly using the UV Texture Editor (Edit UVs->UV Texture Editor or Window->UV Texture Editor).
You can also use the modifiers of your UV creation method. These can be adjusted with the Pivot controls, that are available thats after the creation was selected, or later on, in the Channel Box, at the object inputs.
http://www.abload.de/image.php?img=mayauvs2mdlj.jpg

Lenio Crameri (Lecra) 24.11.2011 08:56
Stefan,

I got it. Thank you! By mistake I deselected the the Pivot control and I was not aware how to come back to the settings. Googeling I found out that the 'place2dTexture' is one way to come back. Another Maya pros in another community pointed me in the right direction telling me that GDN wrote this in the Maya Exporter guidelines what I apparently haven't see. Shame on me.

Thank you any way for your tip Stefan, much appreciated.

KR;Lecra


Note: Log in to post. Create a new account here.