Community Forum

Blender exporter missing normal map

Forum Overview >> Blender Exporter

CategoryBlender Exporter
Created14.01.2013 19:14


Kaosknite (fmc_modding) 14.01.2013 19:20
Hi all,
I've tried using Blender 2.64 and 2.62 with the Blender Exporter 5.0.1. I have not been able to export i3d objects with a normal map. I had no problems with this when I was using the previous version exporter with FS 2011. When the normals are baked and applied in blender I have no problem seeing the normal map in the render, however when I export the object as i3d, it changes the normal map to a texture. Manually changing it to a normal map in notepad only causes it the mesh to turn black. This is frustrating. I tried to find setting in the exporter but didn't see any options except export physics and apply modifiers. I tried different way but still the same thing happens. Has anyone been able to figure out how to export the normal maps? Thanks

Michael Mayer (unknown) 15.01.2013 15:17
You have to add lines in model i3d file.

Kaosknite (fmc_modding) 15.01.2013 17:08
I tried that. It turns the mesh black. Somehow it's not exporting the baked normals.
I made some screen shots to show what I'm doing..maybe I'm missing something.
baked normals:
https://dl.dropbox.com/u/23454226/blender%20screen/bake%20normal.jpg(image removed, problem solved...see below.)

mapping normals:
https://dl.dropbox.com/u/23454226/blender%20screen/normal%20mapping.jpg(image removed, problem solved...see below.)
https://dl.dropbox.com/u/23454226/blender%20screen/normal%20mapping2.jpg(image removed, problem solved...see below.)

render with normal and no diffuse texture:
https://dl.dropbox.com/u/23454226/blender%20screen/render_normal_nodiffuse.jpg(image removed, problem solved...see below.)
render with normal and diffuse textures
https://dl.dropbox.com/u/23454226/blender%20screen/render_with_normalmap.jpg(image removed, problem solved...see below.)

export options:
https://dl.dropbox.com/u/23454226/blender%20screen/export_options.jpg(image removed, problem solved...see below.)

export results in notepad i3d object:
https://dl.dropbox.com/u/23454226/blender%20screen/notepad_i3d.jpg(image removed, problem solved...see below.)

manual edit of i3d in notepad:
https://dl.dropbox.com/u/23454226/blender%20screen/manual_edit.jpg(image removed, problem solved...see below.)

results of manual edit in giants:
https://dl.dropbox.com/u/23454226/blender%20screen/manual_edit_in_giants.jpg (image removed, problem solved...see below.)

I have all but given up trying to make these normals work..any help is appreciated.
Thanks


Sebastian Adler (bazillus) 06.02.2013 12:52
Did you add tangent="true" in shapes section?
Should look like this:
<Vertices count="1234xyz" normal="true" uv0="true" tangent="true">

greetings

Kaosknite (fmc_modding) 06.02.2013 18:24
Thank You So Much Sebastian Adler (bazillus) !!! You have just made my whole week. I don't know how you figured that out but it works like a charm :)


Note: Log in to post. Create a new account here.