Community Forum

Blender doesn't create shape files?

Forum Overview >> Blender Exporter

CategoryBlender Exporter
Created25.04.2016 16:17


Bengt Sæther (Nordvarg) 25.04.2016 16:23
Hi there - hope you are well!

I believe almost every mod I've inspected has at least an i3d file AND a shape file. But when I'm exporting my models from Blender to GE, there's no shapes files - only i3d files.

- I do believe I have read somewhere that Blender doesn't create shape files when models are exported to GE. Is that correct?
- If so, what does it mean for the model's performance in-game? I know they work. But are they working as good as models with shape files?

All the best :)

Emil Drefers (giants.edrefers) 26.04.2016 06:58
Hi,

a i3d.shapes file decreases the loading time.
The performance afterwards is the same.

You should be able to use the GIANTS Editor to create an i3d.shapes file.
Just (re)save the file.

Cheers,
Emil

Bengt Sæther (Nordvarg) 26.04.2016 09:58
Thanks, Emil :)

I've re-saved my models several times using Giants Editor. Still no i3d.shape files.

Any ideas what I'm doing wrong? Most of the time I use the default settings in the Blender exporter.

Emil Drefers (giants.edrefers) 27.04.2016 07:43
Hi,

nope, I'm sorry, but I don't use Blender at all ... only Maya.

When saving with the GIANTS Editor please make sure to select the "Binary i3d files" option and not the "i3d files" option.

Cheers,
Emil

Bengt Sæther (Nordvarg) 27.04.2016 09:00
Thanks Emil :) I'll remember to do that.


Note: Log in to post. Create a new account here.