Community Forum

UV Map (alignment?) problem importing from Blender - help a noob?

Forum Overview >> Blender Exporter

CategoryBlender Exporter
Created20.12.2016 21:28


Brian Poirrier (BrianP) 20.12.2016 21:43
I have been struggling with this for a while and just need some advice.

I have a model in Blender that I have merged all objects to one and created a larger (2048x2048) UV map and texture for it. When I export from blender the map is not aligned or wrong res or something.. but the GE exporter isn't my friend atm.


What it looks like in blender : http://www.filedropper.com/inblender

And in Giants Editor: http://www.filedropper.com/inge

and the .blend file if interested :
Here's the .blend file if interested: http://www.filedropper.com/truck10

I'm not even sure what to elaborate on at this point. I am very new to both programs, so hopefully is something stupid. The documentation for specific procedures is hard to come by and usually involves interpreting something close. I have about 40 hours of just learning UV maps/textures unwrapping etc. and it's starting to click. I have read so many posts here and there's some seriously smart folks on this board, so hoping someone could help.

Thanks!


David Zadnik (DzInLa) 21.12.2016 02:45
First you have unpack the textures that are in the Blender file.

Your textures need to be mapped to the unpacked texture.

Also turn on the Backface Culling as per the "Modding for Dummies" book.


Brian Poirrier (BrianP) 21.12.2016 04:15
The textures are unpacked. I have been packing the texture image file to transfer the blender file to and from work.

The texture is mapped, shows correctly in blender and is showing in GE.. just all funky. It is referenced correctly in the id3 file I believe (it's in the same directory as the id3 file)

<Files>
<File fileId="1" filename="//TextureAtlas.png" relativePath="true" />
</Files>
<Materials>
<Material ambientColor="1 1 1" cosPower="50" materialId="3" name="Baked" specularColor="1.000000 1.000000 1.000000">
<Texture fileId="1" wrap="false" />
</Material>
<Material ambientColor="1 1 1" diffuseColor="0.3 0.3 0.3 1" materialId="2" name="default" specularColor="0 0 0" />
</Materials>

I have turned Backface Culling on, although it doesn't appear to have changed anything in GE.. nothing regarding the UV image for sure. I turned it off once when I was trying to figure out why the back of the faces were transparent in GE .. that's a whole other issue that I have resolved.

I have read the book.. there are 3 pages on how to install the GE export module in Blender (should take 2 sentences) and 1/3 of a page on the settings.

I decided to learn Blender about 2 weeks ago so I know I'm a complete noob, but I'm fairly savvy at computer programs in general. I just wanted to make a flatbed for a truck and it seemed fun to learn how to do it :) I'm 47 and I've never asked for help on a forum in my life.. this one particular issue is just driving me crazy! Mostly because I cannot find any info on this specific problem else I would have figured it out by now I believe. So this is a first for me.
I apologize if I am not explaining my issue correctly. I have tried about every combination of check boxes all with the same result. I bet I have 100 variations so far. I have also rotated the map 90 degrees at a time, inverted it then rotated.. I am just missing something so I'm hoping for someone way smarted than I to point out a probable simple mistake or setting.

Thanks!


David Zadnik (DzInLa) 21.12.2016 18:07
You might want to lock your current Blender scale and rotation to zero before exporting and see if that makes a difference.

Brian Poirrier (BrianP) 21.12.2016 23:15
SOLVED

Thank you for your replies David.. I was thinking along the same lines and was messing with the scale and rotation settings earlier.

What it ended up being was a simple issue.. I don't know if it was my messing around so much, a Texture Atlas issue, or merging the objects.. but the final single object had several UV maps associated with it. In case anyone else has a similar issue, on the Properties Panel, under the Object Properties the UV maps are listed.. I had the right map selected, but once I deleted the unused ones.. Bada-Bing! Just like magic it all come together :) Blender was displaying correctly in render and in the UV Editor.. so I just wasn't looking in that direction.

Thanks again.


Note: Log in to post. Create a new account here.