Community Forum

Exporter Blender 2.8

Forum Overview >> Blender Exporter

CategoryBlender Exporter
Created16.08.2019 15:42


Jorn Hiel (fa285634) 16.08.2019 15:42
Hi, to all the persons reading this. While giants is working on releasing a working one, im putting mine available for all to use

it's on :

https://nld-community.nl/files/file/380-giants-i3d-exporter-for-blender-28/


To use it, do not forget to save before using the exporter, as blender 2.8 needs a save now before it can calculate the relative path's for
the editor

Ayden Longbottom (Aydengamer06) 20.08.2019 22:21
Thank you so much! it actually worked and now i can mod!

Jonas A. L. Andersen (StjerneIdioten) 16.09.2019 20:05
From the "Blender Exporter Plugin - Feedback" thread on the giants forum it sounds like they won't be updating the plugin any time soon themselves. Would you mind if I use your code as a base for implementing some features (fx. collection instance support) that I myself use a lot in the new blender 2.8, but currently does not play so well with the exporter. I was in the process of updating the 2.79 plugin, but I see no reason to do that if you have already done it :P And the reason I am asking for permission is that I would of course like to share any updates I implement, with the rest of the community.

Jorn Hiel (fa285634) 04.10.2019 19:48
contact me trough https://nld-community.nl/ i dont really follow this forum ;) also Jonas, if your updating, be aware that the full exporter is really, really old code, fs11/fs13 age.

Exkitteh Kitteh (exkitteh) 14.10.2019 18:53
Thanks!

Alex Heindl (xxyz85xx) 15.10.2019 00:13
How do you get it into Blender? Im new to this

Giovanni F. (gioFarmer) 18.10.2019 00:26
Hi everyone,
unfortunately I cannot and provided the plug-in to import / export 3D models in Blender,
I installed the 64-bit version of Blender 2.8. I perform these steps:

install the io_export_i3d plug-in in the path: C:\Program Files\Blender Foundation\Blender\2.80\scripts\addons

then: Edit > Preferences > Add-ons > Install add-ons from files

then: select the _init_.py file and click install, it tells me that the module is installed and Save preferences.

unfortunately when I select: File > Import / export not, showing .i3D files option.

I followed what is written on this page, but the result is always the same ...

Giovanni F. (gioFarmer) 18.10.2019 21:08
I solved the problem... reading the other pages of the forum, unfortunately with the translation I had lost some passages ... Thanks

Ravlie 12.12.2019 01:43
Traceback (most recent call last):
File "C:\Users\Ravlie\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\io_export_i3d\i3d_ui.py", line 149, in execute
io_export_i3d.i3d_export.I3DExportAll()
File "C:\Users\Ravlie\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\io_export_i3d\i3d_export.py", line 28, in I3DExportAll
I3DExport(False)
File "C:\Users\Ravlie\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\io_export_i3d\i3d_export.py", line 37, in I3DExport
m_expObj.export(m_exportSelection)
File "C:\Users\Ravlie\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\io_export_i3d\i3d_export.py", line 566, in export
self._generateSceneGraph()
File "C:\Users\Ravlie\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\io_export_i3d\i3d_export.py", line 582, in _generateSceneGraph
self._sceneGraph.generateFiles()
File "C:\Users\Ravlie\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\io_export_i3d\i3d_export.py", line 136, in generateFiles
m_fileItem = I3DFileNode(self._fileID,m_file,m_type)
File "C:\Users\Ravlie\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\io_export_i3d\i3d_export.py", line 86, in __init__
self._data = getFileData(m_treeID,m_type,m_filepath)
File "C:\Users\Ravlie\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\io_export_i3d\dcc\__init__.py", line 296, in getFileData
m_nodeData = dcc.getFileData(m_node,m_nodeData,location)
File "C:\Users\Ravlie\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\io_export_i3d\dcc\dccBlender.py", line 540, in getFileData
if not m_blend[0]==m_nodeStr[0]:
IndexError: string index out of range

location: <unknown location>:-1

Alex Otto (akarvi) 30.12.2019 19:55
@Jorn: nice done!!

Alex Otto (akarvi) 30.12.2019 20:00
double post

Yentl N. Otto (Yentl__5) 06.01.2020 16:52
I have blender 2.81.xx freshly installed. After the new conversion pack getting the response "Need to update to 2.8x"

So not working for me

Christian Schneider (schneidervogelnest) 13.01.2020 16:56
Super Danke. Geht

Yentl N. Otto (Yentl__5) 14.01.2020 19:20
Got it working. Somehow there was a double entry, of which one was the olad 7.1.x version. Deleted that one re-imported yours. Now working fine for me. Thnx

Dadigui93 (DaDiGui93) 02.04.2020 02:03
It's working fine for me so far.

Blender 2.82

DOWNLOAD HERE:
https://nld-community.nl/files/file/380-giants-i3d-exporter-for-blender-28/

Jan Nowak (nowak1282) 04.04.2020 21:14
After installation I don't see it in Add-ons. How to solve it?


Jorn Hiel (fa285634) 06.04.2020 11:22
by reading and following the instructions on the download page. Not by randomly trying things like the install button. That never workd for any of the plugins from giants

David Zadnik (DzInLa) 21.10.2020 16:19
Check out this video link https://youtu.be/lRDPuKh9gow for how to use the new exporter. Watch both tutorials to better understand the exporter.

Also check out the Vertex Design page https://vertexdezign.net/en/blender-exporter-tutorials-6055 for help and a link to the latest version of the exporter.

Works with Blender 2.9

Harry Moon (Harrym26) 13.07.2021 13:38
When i go onto the link it says "We could not locate the item you are trying to view." How do i fix this?

Jonas A. L. Andersen (StjerneIdioten) 13.07.2021 23:10
From what I can tell they have taken it down and someone else has put up a link at NLD to my exporter.
https://github.com/StjerneIdioten/I3D-Blender-Addon


Note: Log in to post. Create a new account here.