Community Forum

Problems with exporting model to .i3d from .obj

Forum Overview >> Blender Exporter

CategoryBlender Exporter
Created12.05.2021 18:43


Naneee ("_") (naneee) 12.05.2021 18:43
Hello to all of you, I don't know if this thread belongs here, but I have a problem. I'm using SketchUp Pro 2018 to create all models. Anyways, in SketchUp, everything looks normal. Every node is here. Same thing in Blender 2.79. Everything looks same. Exporting to .i3d looks normal. But, when I open the .i3d file, every node is flatten and some parts of the model are actually missing. I have searched a lot of forums, but I didn't find any kind of issue I have. Every help will be appreciated.

Greetings, Nane

(also my grammar is very bad, I don't speak English natively)
Edit - I made an mistake, exporting from SketchUp to any 3D model export extension, makes the same problem, sometimes GIANTS Editor crashes while trying to load an mod. I will try to respond as soon as possible. I don't know when will I see the replies. All photos are below. The names of images are jokes, but some of them are actually true.

Naneee ("_") (naneee) 12.05.2021 19:26
Here are all photos that will make this post more understandable (for example, I made an air filter for my tractor project, but it doesn't go as planned...)

https://www.mediafire.com/file/e0pi0yesw7unn7q/issue1.png/file
https://www.mediafire.com/file/5lyov1akecodhuv/I+know,+I+suck+at+drawing+3D+models..png/file
https://www.mediafire.com/file/y25mcvmlzrsfyvs/Everything+looks+normal..png/file
https://www.mediafire.com/file/ip188hdhvyfueqs/I+know,+it's+boring..png/file
https://www.mediafire.com/file/m490pua39ctlmz6/It+loads+correctly,+without+any+issues,+as+you+can+see..png/file
https://www.mediafire.com/file/kbl0dnz91bv7cjd/No+errors+pop+up+while+exporting..png/file
https://www.mediafire.com/file/g6jcwckji9dco40/Everything+looks+normal+in+i3d+file..png/file
https://www.mediafire.com/file/lz29syda7kwajbl/This+is+the+issue+I'm+talking+about..png/file


I hope you now understand the topic. Sorry for the fact you have to download all of the pictures.



David Zadnik (DzInLa) 13.05.2021 04:14
Before exporting from Blender, did you apply Scale to all objects? Ctrl+A S

Naneee ("_") (naneee) 13.05.2021 07:16
I didn't use that, because when importing every model in blender everything looks normal. I will try that later.


Naneee ("_") (naneee) 13.05.2021 10:40
Hey DzInLa, I'm back. I did that what have you said. It's still the same. However, I saw an error in Scripting. - Error:UVs out of range [-8,8] Mesh2 Group2 Group1 Model.

Naneee ("_") (naneee) 13.05.2021 10:41
I will take a screenshot again to show you.

Naneee ("_") (naneee) 13.05.2021 10:47
https://www.mediafire.com/view/ock7hnb8mrbag9t/Still_the_same..png/file
Here is the link of the screenshot. I did what you have said. I'm doing this as a project for my friend for FS 15. :)

Naneee ("_") (naneee) 13.05.2021 10:49
However, exporting from SketchUp to .dae format, loads in blender correctly, but loading it in GIANTS Editor completely crashes. Can a SketchUp program be a problem I have for a year? I didn't download newer version of plugin, I use the official blender plugin from sdk folder. And also a GIANTS Editor 6.0.2. I will try to update a software. See you.

Naneee ("_") (naneee) 13.05.2021 12:36
Little update: I have updated SketchUp to newest version of SketchUp, this time I tried to export a model in collada, but it just crashes. It closes. I will try to send you a crash log.

Naneee ("_") (naneee) 13.05.2021 12:38
Here is the log:
GIANTS Engine Runtime 6.0.2 64bit (Build Date: Oct 27 2014)
Copyright (c) 2008-2014, GIANTS Software GmbH (giants-software.com), All Rights Reserved.
Copyright (c) 2003-2014, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 6.0.2
Main System
CPU: Intel(R) Celeron(R) CPU N3350 @ 1.10GHz
Memory: 3920 MB
OS: Windows NT 6.2 64-bit
Physics System
Version: 5.9.4
Thread(s): 1
Sound System
Driver: OpenAL Software
Render System
Driver: OpenGL
Card Vendor: Intel
Renderer: Intel(R) HD Graphics 500
Version: 4.5.0 - Build 22.20.16.4815
Shader Version: 4.50 - Build 22.20.16.4815
GL_NV_texture_compression_vtc not supported
max_texture_layers: 16
GL_NV_vertex_program2_option not supported
GL_NV_vertex_program3 not supported
GL_ATI_texture_float not supported
Check for updates (http://gdn.giants-software.com)
OpenGL initialization successful
Hardware Profile
Level: Low (auto)
View Distance Factor: 0.750000
Shadow Quality: 0.000000
Skip Mipmaps: 1
LOD Distance Factor: 0.750000
Terrain LOD Distance Factor: 0.750000
Foliage View Distance Factor: 1.000000
Volume Mesh Tessellation Factor: 1.500000
Tyre Tracks Segments Factor: 0.500000
Error: UVs out of range [-8,8] ID37'.
Error: UVs out of range [-8,8] ID80'.
Error: UVs out of range [-8,8] ID157'.
Error: UVs out of range [-8,8] ID6'.
Error: UVs out of range [-8,8] ID24'.
Error: UVs out of range [-8,8] ID46'.
Error: Mesh 'ID165' has zero triangles.
Error: UVs out of range [-8,8] ID88'.
Error: UVs out of range [-8,8] ID133'.
Error: UVs out of range [-8,8] ID141'.
Error: UVs out of range [-8,8] ID149'.
Error: Mesh 'ID175' has zero triangles.
Error: Mesh 'ID171' has zero triangles.
Error: UVs out of range [-8,8] ID104'.
Error: UVs out of range [-8,8] ID125'.
C:\Users\Korisnik\Desktop\Air filter for tractor\testfromcollada.i3d (166.43 ms)


While loading it just crashes and exits from the program.
Can this be the problem with polys?
This is interesting. I have exported the model from .dae to .i3d, but this time I have loaded it in a older version of GIANTS Editor. It loads perfectly. It works. I have no idea what's happening. Only I don't have textures, neither in .i3d file.


Naneee ("_") (naneee) 13.05.2021 14:10
Please, help me. I'm a newbie. I don't even know basics about Blender. Thank you. I have updated every software I have. It doesn't work.

David Zadnik (DzInLa) 14.05.2021 05:10
Is a material assigned to every model?

Naneee ("_") (naneee) 14.05.2021 15:07
Yes, it is, I think. Since I'm from Europe, I can't reply to you in that time because I sleep in this time. In what kind of time zone do you live in? We may be different in everything. How do I check if material is assigned to every model?

Naneee ("_") (naneee) 18.05.2021 21:31
Please, can anyone help me? Thanks for your help. This is very important for me because I want to do this mod as soon as possible. Is this also a problem with PC? Just asking. Thank you everyone.

Bilbo Beutlin (BBeutlin) 18.05.2021 22:31
I'm no gfx expert, more coder. So I can't help much with your Blender problems. But what I do know for sure is that you have to learn how to use Blender, you can't do it in a hurry. You admit "I don't even know basics about Blender". With this knowledge and experience I'd say: forget it!

Apart from that could be really a problem with your rig. 3920 MB RAM is a joke for memory consuming programs like GE and Blender. Alone your OS Win 8 eats 1-2 GB RAM.
Also might be, your GPU Intel HD 500 is at the limit. It is an integrated GPU and uses shared RAM from system instead dedicated VRAM.

All in all your system is too weak for the demands of the GE and a 3D-modeler.

Naneee ("_") (naneee) 31.07.2021 11:29
Oh, ok. Thank you dude! I don't know how, but GE runs flawlessly on my laptop. It's kinda crazy to say that this underpowered machine for $300 back in the day that can't even run Windows properly, lol. I do kinda know the basics about my machine. Anyways, I gave up on my project. Thank you BBeutlin! (sorry for making you mad)

9Tibi9 04.11.2021 19:58
Hello,

I have problem by export in blender the dae file to i3d. As soon as I press to export I have got this message: One or more meshes detected without polygons. Know somebody to help? Thank you

Hungrycowdesign (HungryCow212) 10.11.2021 14:22
Naneee, I hope you come back and see this one day. Don't let conceited curmudgeons like Bilbo discourage you. He is extremely condescending in every single post reply I've ever read from him. He admits he's no graphics expert, but still takes the time to post a reply and talk down to you. Your computer is fine to get started with. I hope you decide to give it another go.

Here's the answer to your problem. You need to edit the UV islands for your model in Blender. When you open the UV editor you will see a grid. Every UV island must be within the first 8 tiles in every direction. You are getting those errors because you have several UV islands that are outside that range. You can either scale them down to fit or break them into smaller islands. You might even be able to simply move them within range. If none of this makes sense I would suggest looking up UV mapping on Youtube. Good luck!


Note: Log in to post. Create a new account here.